X server krasch - fontproblem?!

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
Gandalf
Posts: 14
Joined: 14 June 2003, 14:03

X server krasch - fontproblem?!

Post by Gandalf » 25 November 2003, 10:43

Kör RedHat 9, kernel 2.4.20
X servern kraschar och jag får följande meddelande:

Could not init font path element unix/:7100, removing from list
.....
Fatal Server Error
Could not open default font 'fixed'

Om jag sätter runlevel=3 och gör startx, hjälper det inte.
Problemet är intermittent, ibland funkar det utan problem....

Tacksam för förslag på vad jag kan göra!

User avatar
panzar
Posts: 100
Joined: 23 April 2003, 22:07

Post by panzar » 25 November 2003, 11:17

Har ett svagt minne av detta problem.. Kolla så xfs verkligen är igång?
Annars kan du nog kommentera bort font-raden i XF86Configen så ska den starta?

Gandalf
Posts: 14
Joined: 14 June 2003, 14:03

Post by Gandalf » 25 November 2003, 11:50

Hm, har googlat lite och hittat tips på vad man kan göra.

Ja, det har tydligen att göra med font-servern xfs.
Man ska kolla att den är igång. (# pidof xfs)
Förstår dock inte varför det funkar ibland och ibland inte.

Sedan kan man som du skrev kommentera bort raden
FontPath "unix/:7100"
i /usr/X11R6/lib/X11/XF86Config
och ersätta den med ett antal rader
FontPath "/usr/X11R6/lib/X11/fonts/<file>"
där <file> är fontfiler i detta directory. Är osäker
på vilka som ska användas, det får bli lite trial-and-error.
Själv har jag 11 stycken (Red Hat 9).
Sen kan man kolla resultatet i logg-filen /var/log/XFree86.0.log

Så X kanske fungerar bättre nu.

Post Reply