Page 1 of 1

[LÖST] Xorg.conf <-> XF86Config + FC2 och nVIDIA?

Posted: 22 May 2004, 02:49
by Kimmy
Hej alla... Har precis uppgraderat från Fedora Core 1 till Fedora Core 2, och vad jag har fattat så används inte längre XFree86, utan Xorg... Men jag har fortfarande XF86Config, och ingen Xorg.conf (som det tydligen ska vara)... Har detta någon betydelse? Kan man bara byta namn på XF86Config till Xorg.conf och peta ut den ett steg till /etc (eller vart den nu ska ligga), har de indentisk syntax?


<bortse från, löst!>
Sen undrar jag om någon har fått nVIDIAS drivar att funka med Fedora Core 2, och isåfall hur? (gärna en beskrivning som ett pucko t.o.m. fattar)...

När jag startar X med nVIDIAS drivar så får jag bara en blank skärm, och det enda som funkar för att få tillbaks kontrollen är en hårdreset... Som jag har fattat så har det nått med nått böös som heter K4STACKS att göra...

Har ett Asus V9400 Magic MX4000 (nVIDIA) och kernel 2.6.5... Och nVIDIAS Open Source-drivar suger verkligen på alla sätt... :cry:
</bortse från, löst!>

Posted: 22 May 2004, 09:55
by bux
Så här ser min /etc/X11/xorg.conf ut (använder fedora core 2 med egen kompilerad linux för att kunna använda nvidias closed source drivisar):

Code: Select all

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "se"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Unprobed Monitor"
	HorizSync    30.0 - 95.0
	VertRefresh  50.0 - 150.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
#	Option	    "NoLogo" "true"
#	Option	    "RenderAccel" "true"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
Det enda jag ändrat är "nv" till "nvidia" för nvidias closed source drivisar.

EDIT: just ja, jag har lagt till två options till nvidia drivrutinen också... fast de är bort kommenterade ändå iof.

Posted: 22 May 2004, 21:46
by Kimmy
Oki... Den ser ju faktiskt identisk ut med XF86Config... :)
Tackar... Ska prova att byta namn på den och starta om... :)

Posted: 23 May 2004, 21:33
by polly_morf
Kimmy wrote:Oki... Den ser ju faktiskt identisk ut med XF86Config... :)
Tackar... Ska prova att byta namn på den och starta om... :)
Funkade det? Jag har nämligen inga startdisketter så jag får fet-problem om jag försöker starta med NVidia drivers. (måste hålla på med knoppix).

Posted: 23 May 2004, 23:10
by Kimmy
polly_morf wrote:
Kimmy wrote:Oki... Den ser ju faktiskt identisk ut med XF86Config... :)
Tackar... Ska prova att byta namn på den och starta om... :)
Funkade det? Jag har nämligen inga startdisketter så jag får fet-problem om jag försöker starta med NVidia drivers. (måste hålla på med knoppix).
Oj... Jag borde nog känna mig lite dum nu, jag har nämligen inte bootat om ännu... *S* :-? :oops:

Posted: 24 May 2004, 13:27
by polly_morf
Kimmy wrote: Oj... Jag borde nog känna mig lite dum nu, jag har nämligen inte bootat om ännu... *S* :-? :oops:
Har du bootat om nu? :P

Funkade det?

Posted: 26 May 2004, 11:22
by Kimmy
Japp! Nu har jag bootat om... Nemas problemas, funkar fin-fint... :)