Python = Python

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
User avatar
Caw
Posts: 39
Joined: 16 June 2004, 20:39

Python = Python

Post by Caw » 20 June 2004, 16:45

När jag försöker få men nyaste versionen av Python (2.3.4) så säger den att jag har den nyaste fast jag bara har 2.1?

Kör Debian, och försöker hämta det via apt-get.

Code: Select all

debian:/home/caw# apt-get install python
Reading Package Lists... Done
Building Dependency Tree... Done
Sorry, python is already the newest version.
0 packages upgraded, 0 newly installed, 0 to remove and 0  not upgraded.
Är det jag som gör nåt fel eller?
Är nybörjare :wink:
caw@angel:~$ ls /etc/lilo.conf
/etc/lilo.conf

Burnis
Posts: 760
Joined: 4 January 2004, 23:49
Location: Firefox
Contact:

Post by Burnis » 20 June 2004, 16:48

Det betyder att du redan har den senaste verisionen installerad..
Image

User avatar
Caw
Posts: 39
Joined: 16 June 2004, 20:39

Post by Caw » 20 June 2004, 16:50

Ja, men jag har inte det :-?
caw@angel:~$ ls /etc/lilo.conf
/etc/lilo.conf

Lucifer888
Posts: 4111
Joined: 3 February 2003, 12:18
Location: Stockholm

Post by Lucifer888 » 20 June 2004, 16:55

Caw wrote:Ja, men jag har inte det :-?
Finns det inte så att man kan skriva "apt-get reinstall python" om det blivit något fel? kolla i manualen, inte använt apt-get så kan inte syntaxerna
"It's not that I hate people, I just think they're all idiots"
"Långt hår kräver mycket näring, framhålls det, och berövar hjärnan energi."

User avatar
Caw
Posts: 39
Joined: 16 June 2004, 20:39

Post by Caw » 20 June 2004, 17:15

Skumt, den laddar bara hem 2.1, inte 2.3?

Code: Select all

debian:/home/caw# apt-get --reinstall install python
Reading Package Lists... Done
Building Dependency Tree... Done
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0  not upgraded.
Need to get 25.5kB of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n] y
Get:1 http://security.debian.org stable/updates/main python 2.1.3-3.2 [25.5kB]
Fetched 25.5kB in 0s (114kB/s)
(Reading database ... 19684 files and directories currently installed.)
Preparing to replace python 2.1.3-3.2 (using .../python_2.1.3-3.2_all.deb) ...
Unpacking replacement python ...
Setting up python (2.1.3-3.2) ...
caw@angel:~$ ls /etc/lilo.conf
/etc/lilo.conf

User avatar
dr_van_nostrand
Posts: 402
Joined: 15 October 2003, 20:39
Location: Linköping
Contact:

Post by dr_van_nostrand » 20 June 2004, 17:22

Finns 2.3 i din version av Debian då?
Är inte säker på att Woody(stable) kör med 2.3.
Naiv - Roligare så!

User avatar
Caw
Posts: 39
Joined: 16 June 2004, 20:39

Post by Caw » 20 June 2004, 17:25

Borde väl gå att hämta "nyare" packet än vad som följde med 3.0?
Finns det nån instaälling så den gör det?
caw@angel:~$ ls /etc/lilo.conf
/etc/lilo.conf

User avatar
dr_van_nostrand
Posts: 402
Joined: 15 October 2003, 20:39
Location: Linköping
Contact:

Post by dr_van_nostrand » 20 June 2004, 17:32

Du kan ju ändra i inställningarna för apt så att du hämta allt från tex testing eller unstable. Vad använder du datorn till? Om du inte har jättekrav på stabiliteten så funkar testing bra. Kommer inte ihåg exakt hur man ställer in men det bör gå att hitta någonstans här på forumet. Du kan använda den norska servern istället för den svenska då den är mycket snabbare.
Naiv - Roligare så!

User avatar
Caw
Posts: 39
Joined: 16 June 2004, 20:39

Post by Caw » 20 June 2004, 17:43

Håller på att lära mig linux, det har jag datorn till :D
Vill gärna använda stable...

Är ny på linux, hur ändrar jag inställningarna för apt så att den hämtar allt från tex testing eller unstable?

---

Download Python for Linux
Most Linux distributions have Python installed. If you want a newer version, you can build from the source; sometimes RPMs are also available. See the individual releases for details.


Står det på Pythons hemsida.

Om jag bygger den från source...skriver den över 2.1 eller blir det en massa konstiga konflikerer mellan 2.1 och 2.3?
caw@angel:~$ ls /etc/lilo.conf
/etc/lilo.conf

Lucifer888
Posts: 4111
Joined: 3 February 2003, 12:18
Location: Stockholm

Post by Lucifer888 » 20 June 2004, 17:45

Caw wrote:Om jag bygger den från source...skriver den över 2.1 eller blir det en massa konstiga konflikerer mellan 2.1 och 2.3?
säkrast att avinstallera gamla versioner först, men det kan skriva över om apt-get och sourcen installerar till samma ställe
"It's not that I hate people, I just think they're all idiots"
"Långt hår kräver mycket näring, framhålls det, och berövar hjärnan energi."

User avatar
Caw
Posts: 39
Joined: 16 June 2004, 20:39

Post by Caw » 20 June 2004, 17:51

När jag bygger från source...var ska jag köra ./configure och make?

Jag har sparat den i /home/caw och där packat upp den.
Om jag kör ./configure och sedan make, installeras den i /home/caw/Python 2.3 eller där den "ska" ligga?
caw@angel:~$ ls /etc/lilo.conf
/etc/lilo.conf

User avatar
Kimmy
Posts: 126
Joined: 10 January 2004, 23:10
Location: Skövde
Contact:

Post by Kimmy » 27 June 2004, 07:12

Caw wrote:När jag bygger från source...var ska jag köra ./configure och make?

Jag har sparat den i /home/caw och där packat upp den.
Om jag kör ./configure och sedan make, installeras den i /home/caw/Python 2.3 eller där den "ska" ligga?
Gör typ såhär:

Code: Select all

du@localhost python# ./configure
du@localhost python# make
du@localhost python# su
Password:
root@localhost python# make install
Då installeras det globalt...
Too late... My time has come, send shivers down my spine, body's aching all the time.
Goodbye everybody! - I've got to go! ... Gotta leave you all behind and face the truth...

Post Reply