Page 1 of 1

kompilerings problem (gtk+)

Posted: 20 July 2004, 22:15
by MiDiaN
försöker installera GTK+ som gimp använder sig av (multiplatform tool-kit för att skapa grafiska användar gränssnitt http://www.gtk.org) men stöter på problem:

Jag har installerat alla bibliotek GTK+ kräver (Glib, pango, ATK) och alla gick att installera problemfritt. Men när jag försöker confa GTK+ så kommer detta upp:

Code: Select all

checking for glib-2.0 >= 2.4.0    atk >= 1.0.1    pango >= 1.4.0... Requested 'pango >= 1.4.0' but version of Pango is 1.2.5
configure: error: Library requirements (glib-2.0 >= 2.4.0    atk >= 1.0.1    pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
nån som vet hur jag löser detta?

Posted: 20 July 2004, 22:22
by bux
Det står att du har pango version 1.2.5 installerat men du behöver ha pango version 1.4.0 eller senare installerat.

Posted: 20 July 2004, 22:39
by MiDiaN
oja, glömde att säga, jag har redan installerat pango 1.5.1, glib 2.5.0, atk 1.0.3... men det står ändå att jag har nån gammal version av dessa bibliotek... :(

Posted: 21 July 2004, 07:56
by fork
Har du pkg-config installerat? Annars kan du göra precis som det står: justera PKG_CONFIG_PATH .

Tips: Använd Google. Sök med strängen
consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
och du hittar massor av hjälp.

Posted: 22 July 2004, 20:37
by MiDiaN
Jo jag hittade hjälp och fick några tips från sidor, men ändå krånglar det sig... det jag gjorde var att jag först sökte efter pkgconfig med kommandot whereis pkgconfig och sen skrev jag export PKG_CONFIG_PATH="/usr/lib/pkgconfig"

Men när jag skriver ./configure i gtk mappen så kommer det ett nytt fel:

Code: Select all

checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.4.0    atk >= 1.0.1    pango >= 1.4.0... Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3

configure: error: Library requirements (glib-2.0 >= 2.4.0    atk >= 1.0.1    pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
jag har inte installerat GLib 2.2.3, jag installerade GLib 2.5.0 (nyaste)... så jag undrar varifrån han får det där 2.2.3 :-?

Posted: 23 July 2004, 15:37
by MiDiaN
Tror det har att göra med att jag har 2 Glib versioner på 2olika ställen... är det bara att ta bort den gamla då lr? och var finns dom? har också 2st pango versioner på 2olika ställen... :-?

Posted: 23 July 2004, 16:03
by Bar-Code
Vilken distribution kör du?

Posted: 23 July 2004, 21:06
by MiDiaN
Mandrake 10.0 Official.

Posted: 23 July 2004, 21:43
by fork
Vad ska du med den senaste gtk+ till? Mandrake har säkert färdigkompilerat .rpm som är rätt fräsch och duger för flesta?

Posted: 23 July 2004, 22:13
by MiDiaN
jag får inte gimp 2.0 installerad :( när jag kör ./configure så dyker detta upp:

Code: Select all

checking for GLIB - version >= 2.2.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: Test for GLIB failed. See the file 'INSTALL' for help
jag har prövat att skriva ./configure --disable-glibtest men då kommer nästa problem:

Code: Select all

checking for GTK+ - version >= 2.2.2... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.
vet inte varför det inte hittar gtk+ för när jag skriver in kommandot pkg-config --modversion gtk+-2.0 så visar det 2.2.4 ...
:x

Posted: 23 July 2004, 22:18
by fork
http://www.experts-exchange.com/Operati ... 83255.html Kanske hjälper att installera gimp2, om det inte är med på Mandrake-CD. Låter mysko, tycker jag. ./configure-script blir lätt förvirrat om man har flera versioner av samma program/bibliotek installerat.

Posted: 23 July 2004, 22:28
by MiDiaN
haha "Sign up to view the solution" och att registrera sig kostar pengar... :P men iaf jag hittade rpm's om gtk+2 men jag måste vara mandrake club member :x

Posted: 24 July 2004, 23:33
by MiDiaN
ah crap får det inte installerat :(

Posted: 24 July 2004, 23:58
by Kimmy
MiDiaN wrote:haha "Sign up to view the solution" och att registrera sig kostar pengar... :P men iaf jag hittade rpm's om gtk+2 men jag måste vara mandrake club member :x
Scrolla ner lite på sidan, det finns faktiskt en diskussion under som anknyter till dina funderingar...