Nyborjare i Linux SuSE

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
Guest

Nyborjare i Linux SuSE

Post by Guest » 1 November 2004, 23:39

Har installerat SuSE LINUX Professional 9.1 pa datorn. Forsta intrycket ar an sa lange bra, men det ar nagra saker som jag redan nu vill ha reda pa.

Som ni ser fungerar inte Svenska i SuSE just nu, hur fixar jag det?

For det andra, skarmupplosningen ar just nu pa 1024x768, hur fixar jag hogre upplosning? Finns en dropdown men dar ar 1024x768 max, men pa windows kunde jag ha hogre upplosning.

Detta var det jag ville ha reda pa nu, kommer sakerligan stalla mer fragor senare :wink:

User avatar
JO
Posts: 12419
Joined: 1 May 2002, 02:00
Contact:

Post by JO » 1 November 2004, 23:47

Jo då allt funkar. Men du måste göra en del *manuellt*;)
/etc/sysconfig/keytables. sv-latin1.
Registered User # 259689 http://counter.li.org
First humans moved out of caves;
then they invented writing;
now they invented intuitive GUIs;
all that remains is to return to caves.

User avatar
st3f
Posts: 187
Joined: 19 November 2003, 00:19
Location: Norrköping/Stockholm

Post by st3f » 1 November 2004, 23:48

Suses "kontrollpanel" kallas Yast, där borde du kunna ändra det mesta. Du hittar den säkert i "startmenyn".
Slackware 10.1 (2.4.29)
Enlightenment 0.16.7
http://www.skrivihop.nu/ snälla!

Guest

Post by Guest » 1 November 2004, 23:48

JO wrote:Jo då allt funkar. Men du måste göra en del *manuellt*;)
/etc/sysconfig/keytables. sv-latin1.
Hehe, var ska jag skriva det? :wink: :oops:

User avatar
JO
Posts: 12419
Joined: 1 May 2002, 02:00
Contact:

Post by JO » 1 November 2004, 23:55

Spindel wrote:
JO wrote:Jo då allt funkar. Men du måste göra en del *manuellt*;)
/etc/sysconfig/keytables. sv-latin1.
Hehe, var ska jag skriva det? :wink: :oops:
Starta ett shell och "su" till root. Öppna filen i din favorit editor.
Lägg in sv-latin1 och spara.
Du kan testa i ett shell, genom att skriva; loadkeys sv-latin1.
Registered User # 259689 http://counter.li.org
First humans moved out of caves;
then they invented writing;
now they invented intuitive GUIs;
all that remains is to return to caves.

Guest

Post by Guest » 2 November 2004, 00:26

JO wrote:
Spindel wrote:
JO wrote:Jo då allt funkar. Men du måste göra en del *manuellt*;)
/etc/sysconfig/keytables. sv-latin1.
Hehe, var ska jag skriva det? :wink: :oops:
Starta ett shell och "su" till root. Öppna filen i din favorit editor.
Lägg in sv-latin1 och spara.
Du kan testa i ett shell, genom att skriva; loadkeys sv-latin1.
Hur startar jag ett shell och su da? :-?

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 2 November 2004, 00:40

Spindel wrote:
JO wrote:
Spindel wrote: Hehe, var ska jag skriva det? :wink: :oops:
Starta ett shell och "su" till root. Öppna filen i din favorit editor.
Lägg in sv-latin1 och spara.
Du kan testa i ett shell, genom att skriva; loadkeys sv-latin1.
Hur startar jag ett shell och su da? :-?
Använder du KDE eller Gnome så finns det något som heter "terminal" eller "xterm" någonstans i menyerna. Annars kan du öppna "startmenyn" och leta upp "kör". Skriv xterm och tryck enter.

När du sedan har öppnat en terminal/shell så skriver du "su" . Då kommer den att fråga efter ett lösenord. Då skriver du in ditt root-password bara.
Image

Använder Ubuntu Dapper.

Guest

Re: Nyborjare i Linux SuSE

Post by Guest » 2 November 2004, 01:18

Spindel wrote:Som ni ser fungerar inte Svenska i SuSE just nu, hur fixar jag det?
Yast > Leta efter tangentbords-layout > Byt till finskt! =)

Funkade för mig!

Guest

Re: Nyborjare i Linux SuSE

Post by Guest » 2 November 2004, 10:49

Xaddam wrote:
Spindel wrote:Som ni ser fungerar inte Svenska i SuSE just nu, hur fixar jag det?
Yast > Leta efter tangentbords-layout > Byt till finskt! =)

Funkade för mig!
Tackar! Det fungerade! :D

User avatar
JO
Posts: 12419
Joined: 1 May 2002, 02:00
Contact:

Re: Nyborjare i Linux SuSE

Post by JO » 2 November 2004, 12:24

Spindel wrote:
Xaddam wrote:
Spindel wrote:Som ni ser fungerar inte Svenska i SuSE just nu, hur fixar jag det?
Yast > Leta efter tangentbords-layout > Byt till finskt! =)

Funkade för mig!
Tackar! Det fungerade! :D
Lite osnyggt bara;)
Bättre att ändra till svenskt i /etc/sysconfig/keyables.
När du ändå håller på, kan du också ändra i /etc/inittab.
Ändra till runlevel 3. Så slipper du ha en grafisk inloggning;-)
Shell eller terminal är det du behöver. I KDE symboliseras det med ett snäckskal.
Finns även i menyn, under "system". Om jag minns rätt.
Du kommer att behöva den kunskapen.
Registered User # 259689 http://counter.li.org
First humans moved out of caves;
then they invented writing;
now they invented intuitive GUIs;
all that remains is to return to caves.

Guest

Re: Nyborjare i Linux SuSE

Post by Guest » 2 November 2004, 12:49

JO wrote:
Spindel wrote:
Xaddam wrote: Yast > Leta efter tangentbords-layout > Byt till finskt! =)

Funkade för mig!
Tackar! Det fungerade! :D
Lite osnyggt bara;)
Bättre att ändra till svenskt i /etc/sysconfig/keyables.
När du ändå håller på, kan du också ändra i /etc/inittab.
Ändra till runlevel 3. Så slipper du ha en grafisk inloggning;-)
Shell eller terminal är det du behöver. I KDE symboliseras det med ett snäckskal.
Finns även i menyn, under "system". Om jag minns rätt.
Du kommer att behöva den kunskapen.
Står att den inte kan hitta filen eller mappen :-?

User avatar
JO
Posts: 12419
Joined: 1 May 2002, 02:00
Contact:

Post by JO » 2 November 2004, 21:42

Vilken då? inittab eller keytables?
Registered User # 259689 http://counter.li.org
First humans moved out of caves;
then they invented writing;
now they invented intuitive GUIs;
all that remains is to return to caves.

Getrb
Posts: 1150
Joined: 28 October 2002, 17:26
Location: Trollhättan
Contact:

Post by Getrb » 3 November 2004, 09:36

Det självklara svaret på din fråga är ANVÄND "sax2".

Du kan med en texteditor ändra i "/etc/X11/XF86config" också om du vill.
Lite att kopiera om så önskas: (ta inte med capslock raden bara så har du en basinställning)

Code: Select all

Section "InputDevice"
  Driver       "Keyboard"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "se,se"
  Option       "XkbModel" "pc105"
  Option       "XkbOptions" "caps"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "xfree86"
EndSection
Jag rekommenderar dock att du kör sax2 där ändrar du tangentbordslayout till "PC105" istället för PC104.
Där ändrar du också upplösning till önskad preferens!

En liten varning bara när du sedan får förfrågan om att "testa" _gör_ det! Detta ger dig dessutom möjligheter att fintrimma skärmplaseringen mm.

För att klara dig lite bättre sedan kolla alltid i Yast.
Sök på detta forum nästan allt har varit frågat förut.
Google + linux är också bra + läs FAQ-delen i forumet.
Lycka till ;-)

temptraq
Posts: 19
Joined: 7 March 2004, 10:36

Post by temptraq » 5 November 2004, 13:50

Getrb wrote:Det självklara svaret på din fråga är ANVÄND "sax2".
Lysande! Tack!

Guest

Post by Guest » 6 November 2004, 19:59

JO wrote:Vilken då? inittab eller keytables?
keytables

Zach
Posts: 257
Joined: 1 December 2002, 20:14
Location: Linköping

Post by Zach » 6 November 2004, 20:42

Spindel wrote:
JO wrote:Vilken då? inittab eller keytables?
keytables
Rätt ska vara '/etc/sysconfig/keyboard'...

Post Reply