Page 1 of 1

[Löst] Hitta rätt paket till Slackware 10?

Posted: 14 January 2005, 23:00
by st3f
Jag installerade om Slack 10 för ett tag sedan men har nu upptäckt att jag saknar vissa program, närmare bestämt "host" och "nslookup" bland annat. Hur vet jag vilket paket jag hittar dessa i så jag kan installera dem igen?

Posted: 14 January 2005, 23:01
by JO
Borde ligga i n/

Posted: 14 January 2005, 23:05
by Bar-Code
Om du installerar pakethanteraren swaret så kan du sen använda swaret för att leta reda på alla såna här saker automatiskt åt dig i framtiden. Väldigt smidigt! Det har alltid varit ett av de första programmen jag installerar när jag smäller in Slackware i burken.

Posted: 14 January 2005, 23:06
by st3f
OK, tack, jag ska kolla in n/ och swaret!

Posted: 14 January 2005, 23:22
by Routh
Finns ju en fin sökfunktion på slackware.com för att hitta paket. Till och med filer i paket om jag inte minns fel?

Posted: 14 January 2005, 23:34
by Bar-Code
Om man vill hitta i vilket paket som ett visst bibliotek finns så funkar slackpkg väldigt bra. Det är en pakethanterare precis som swaret. Själv gillar jag swaret bättre, men just om man undrar vilket paket man måste installera för att få in ett visst bibliotek i systemet eller liknande så är slackpkg alldeles underbart.

Posted: 14 January 2005, 23:41
by JO
st3f wrote:OK, tack, jag ska kolla in n/ och swaret!
Håll igen lite med Swaret och vänta tills 2.0.0test1 släpps.
Det är den nya omskriven i perl.

Posted: 18 January 2005, 01:08
by LINJEinc
JO wrote:
st3f wrote:OK, tack, jag ska kolla in n/ och swaret!
Håll igen lite med Swaret och vänta tills 2.0.0test1 släpps.
Det är den nya omskriven i perl.
måste vara dum & blind jag, då jag inte hittar "swaret" till slack 10 :cry:

Posted: 18 January 2005, 01:18
by Bar-Code
LINJEinc wrote:
JO wrote:
st3f wrote:OK, tack, jag ska kolla in n/ och swaret!
Håll igen lite med Swaret och vänta tills 2.0.0test1 släpps.
Det är den nya omskriven i perl.
måste vara dum & blind jag, då jag inte hittar "swaret" till slack 10 :cry:
Ligger i "extra" katalogen. Eller gjorde det förut i alla fall.

Posted: 18 January 2005, 07:54
by hakan
Det var lite bråk så den togs bort, nu är det en ny "ansvarig".
http://swaret.sourceforge.net/index.php.
Lite från en annan tråd..
Ni kan lika gärna använda "developmentversionen" 1.7.0test4, den är stabil nog.
Kom ihåg att swaret gör, dessvärre, precis vad du säger åt den, och inte alltid vad du ville.. så läs manualen.. :wink:
Ex.v. är det en bra ide att ställa in "Rollback" så att du kan gå tillbaka när det strular, kolla in deras forum, där kommer olika varningar då och då.
Min "EXCLUDE"..
EXCLUDE=kernel alsa-driver
EXCLUDE=lilo swaret
EXCLUDE=MANIFEST.bz2$
EXCLUDE=.*dl$ .*PACKAGER$ .*MYBUILD$
EXCLUDE=python
..ex.v. sabbas ljudet om du inte har dom alsaprylar som din kärna kompilerats med.
"Python", därför att jag inte vet vad som händer med dom program jag redan använt min installerade version till om jag uppgraderar.
Används swaret på "rätt sätt", d.v.s. man vet vad den gör, så är den ett mycket bra hjälpmedel tycker jag. :)
/Håkan

Posted: 18 January 2005, 08:30
by JO
En varning bara Swaret är duktig, på att ställa till problem i sytemet.
Testade fanskapet i går. Den tyckte inte att tar behövdes.
Försök att installera något efter det.

Posted: 18 January 2005, 14:01
by Biffy
Vad är devel versionen under "Downloads" ?

"Try out the new compile."

Kommer Swaret i nästa version att kompilera alltså?

Posted: 18 January 2005, 16:32
by marlinster
Det är paketet "bind" du leter efter, ta hem den och kör installpkg