Undertext program

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
breadandfalafel
Posts: 185
Joined: 15 December 2004, 22:31

Undertext program

Post by breadandfalafel » 22 May 2005, 15:49

Finns det något liknande vobsub till Ubuntu?
Mitt VLC och Xine kan IBLAND läsa .srt filer men inte .sub eller .idx hos mig.

Så då frågar jag en till fråga. Finns det något program som man kan omvandla .sub till .srt?

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 22 May 2005, 16:55

Mplayer kan läsa 12 textningsformat (MicroDVD, SubRip, OGM, SubViewer, Sami, VPlayer, RT, SSA, AQTitle, JACOsub, PJS samt vår egna: MPsub) och DVD-textning (SPU-ström, VOBsub och Closed Captions). Den kan även konvertera till srt och några andra format.

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 22 May 2005, 19:33

Textfilen måste ha samma namn som filmfilen för att det ska funka i xine. Tex:

brafilm.avi
brafilm.sub
Image

Använder Ubuntu Dapper.

breadandfalafel
Posts: 185
Joined: 15 December 2004, 22:31

Post by breadandfalafel » 22 May 2005, 22:50

MPlayer gick inte att installera av någon sjuk anledning. Ska installera om hela mitt system någon dag i veckan och se ifall det går bättre.

Och det fungerar inte att döpa .sub filerna likadant som filmen heller. Händer absolut ingenting. Dock så fungerar det perfekt med .srt.

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 22 May 2005, 22:58

Det funkar inte att helt enkelt byta namn till .srt då? text.sub > text.srt

Vad fick du för fel med mplayer? Vi kan säkert hjälpa dig.
Image

Använder Ubuntu Dapper.

breadandfalafel
Posts: 185
Joined: 15 December 2004, 22:31

Post by breadandfalafel » 23 May 2005, 20:00

Namnbyte fungerade tyvärr inte!

När jag ska intallera mplayer-386 så får jag följande filberoenden som inte går att lösa:

Code: Select all

mplayer-386:
  Beror: libartsc0 but 1.2.3-1 is to be installed
  Beror: libasound2 but 1.0.5-1ubuntu1 is to be installed
 Beror: libavcodeccvs but it is not going to be installed
 Beror: libbio2jack0 but it is not going to be installed
  Beror: libc6 but 2.3.2.ds1-13ubuntu2.2 is to be installed
  Beror: libfontconfig1 but 2.2.2-2ubuntu3 is to be installed
  Beror: libfribidi0 but 0.10.4-3 is to be installed
 Beror: libggi2 but it is not going to be installed
  Beror: libglib2.0-0 but 2.4.7-0ubuntu2 is to be installed
 Beror: libjack0.80.0-0 but it is not going to be installed
  Beror: libogg0 but 1.1.0-1 is to be installed
  Beror: libpng12-0 but 1.2.5.0-7ubuntu1 is to be installed
 Beror: libpostproc0 but it is not going to be installed
  Beror: libsdl1.2debian but 1.2.7-7 is to be installed
  Beror: libungif4g but 4.1.0b1-6 is to be installed
  Beror: libvorbis0a but 1.0.1-1 is to be installed
 Beror: libxvidcore4 but it is not going to be installed
  Beror: xmms but 1.2.10-1 is to be installed
Och med mplayer-custum så får jag följande:

Code: Select all

mplayer-custom:
 Beror: libavcodec2 but it is not going to be installed
 Beror: libpostproc0 but it is not going to be installed
 Beror: libxvidcore4 but it is not going to be installed

zuhat
Posts: 361
Joined: 24 December 2002, 04:41
Contact:

Post by zuhat » 24 May 2005, 17:47

Här är en bra guide till hur man installerar, kanske det hjälper
http://bbs.linux.se:/viewtopic.php?t=11630
~ zuhat ~ zlackware ~
~ linux user #285160
~ LFS user #13183

Post Reply