ljud och diverse andra störande problem.

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

ljud och diverse andra störande problem.

Post by Lucif3r » 29 August 2005, 01:45

Hejsan.

Jag har nu kört linux (ubuntu) i snart 3 månader och trvs jätte bra med det...
Men jag har några problem :roll: ..

Ljudet i linux är rent ut sagt askasst.. låter nästan "metalliskt" och "skrikigt"...
Är speciellt när man lyssnar på musik i XMMS... spelar ingen roll hur jag sätller in EQn.. låter lika illa för det..

Så... vad kan man göra åt detta? Har sökt efter drivrutiner till ljudkortet (AC97.. inbyggt i moderkortet) och kommit fram till att det är ALSA som ska vara till det... Har prövat dom men det låter lika illa för det...

Obs. I windows låter det inte illa.. där låter det som det ska... kan ha att göra med att det finns en equalizer som ändrar allt ljud...
Finns det nån liknande till linux? Har sökt som en tok på google efter en men inte hittat nån :(


Sen ett annat problem:
Mitt linux har en förmåga att tvärlåsa sig efter ca 8-9 dagar (senast idag) så man måste trycka på reset...
Varför händer detta?
Vad kan man göra åt det?
Jag kör gnome och trivs bra med det för övrigt...


Mja... tips osv uppskattas... :lol:

Tack på förhand 8)

EDIT: ajuste ni kanske vill veta min PC specs :)
AMD XP 2800+ barton
1024mb PC3200 RAM
GeForce FX5700 256mb
10Gb 5400rpm HDD (xbox orginal disk)

Så datorn är ju inte direkt dålig... ska väl vara HDDn som är lite kass isf..

phm
Posts: 778
Joined: 17 June 2005, 00:29

Post by phm » 29 August 2005, 01:52


eni
Posts: 129
Joined: 27 August 2005, 00:10

Post by eni » 29 August 2005, 01:52

angaende ljud...oppna konsollen..kor kommandot alsamixer och prova att sanka ljudet..det later som om du har maxat ljudet..sank det till ca 90%

problem 2..kan vara en Linux Kernel Crash elelr nagot liknande..svart o saga...kolla vad loggarna sager...du har alla loggar har /var/log ..kolla speciellt under /var/log/messages

edit: tuxa...hehe..forsok inte tvinga pa folk det dar kassa FC4..ingen vill ha det iaf..=)

din dator ar perfekt for linux...om den skulle vara nyare sa kunde du fa problem med hardvarustodet...sa...=)
en sak till...nu ar det kanske inte sa viktigt..men nar du anger specs:en glom inte moderkort och typ av chipset pa det....
"When you know Slackware, you know Linux... when you know Red Hat, all you know is Red Hat."
- http://en.wikipedia.org/wiki/Slackware
aka amWaW @ forum.slackware.se

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 02:02

ok tack för svaret... tror ljudet vart lite bättre... men det låter fortfarande inte bra... och kan ju inte direkt påstå att det är högt ljud heller :P ...

Kollade igenom den där loggen lite snabbt men fattade inte så mycket... men det hände rätt så mycket under den tiden då datorn frös...

hehe ok kul att höra att man hade en "perfekt" dator för linux då :)... Körde på en 1333mhz förut men där funkade varken ljudkortet eller nätverkskortet utan att skriva massor i terminalen varje gång man skulle t ex kolla på en film...

Moderkortet är ett Epox 8K9A7I

Edit: Fedora... tack men nej tack :D

eni
Posts: 129
Joined: 27 August 2005, 00:10

Post by eni » 29 August 2005, 03:19

du kan prova med kommandot su -c alsaconf
"When you know Slackware, you know Linux... when you know Red Hat, all you know is Red Hat."
- http://en.wikipedia.org/wiki/Slackware
aka amWaW @ forum.slackware.se

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 11:06

bash: alsaconf: Command not found
:roll:

eni
Posts: 129
Joined: 27 August 2005, 00:10

Post by eni » 29 August 2005, 11:12

hmm..ingen alsaconf..de var illa..kolla om du kan installera det nagonstans ifran...om du har alsamixer da maste du ocksa ha alsaconf ...eller anvander ubuntu nagot annat istallet for alsaconf, nagon som vet ???
"When you know Slackware, you know Linux... when you know Red Hat, all you know is Red Hat."
- http://en.wikipedia.org/wiki/Slackware
aka amWaW @ forum.slackware.se

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 11:17

mja jag vet inte...
Sökte efter alsaconf via "apt-cache search" och det enda jag fick fram var alsa-utils... och det verkar inte gå att starta.. :-?

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 29 August 2005, 14:13

alsaconf tillhör alsa-utils.
Med det installerat så borde du ha alsaconf.
Ditt dåliga ljud är nog för att du kör oss nu och inte alsa.
Vad ser du i lsmod??
Alsas ljud moduler börjar med snd, så börjar dom inte med snd kör du oss.
Du sa att alsa-utils inte gick att starta,
alsa-utils är en samling med ljudverktyg.
Alsamixer aplay mm.
Så du startar inte alsa-utils utan du använder verktygen du får med.
The more linux u go, The slacker u get

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 15:59

ah ok... men nån alsaconf har jag inte iaf..

lsmod visar snd_enmassasaker så jag kör väl ALSA isf? :-?

User avatar
JO
Posts: 12419
Joined: 1 May 2002, 02:00
Contact:

Post by JO » 29 August 2005, 16:52

Lucif3r wrote:ah ok... men nån alsaconf har jag inte iaf..

lsmod visar snd_enmassasaker så jag kör väl ALSA isf? :-?
Både ja och nej. I 2.6.x.x kärnan ingår Alsa-modulerna, men inte verktygen.
Har du installerat det övriga?
Registered User # 259689 http://counter.li.org
First humans moved out of caves;
then they invented writing;
now they invented intuitive GUIs;
all that remains is to return to caves.

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 17:30

ja alltså... jag har alla ALSA moduler/verktyg etc som jag har hittat via apt-cache search... inklusive alsa-utils...

eni
Posts: 129
Joined: 27 August 2005, 00:10

Post by eni » 29 August 2005, 20:37

han fick ju igang alsamixer...dock inte alsaconf..intressant det...du kan hamta alsaconf som source..men..hehe...ja..vet inte om det hjalper..=)
http://www.alsa-project.org/alsa/ftp/driver/alsaconf/
EDIT: testa detta da.. su -c 'slocate -u'
sedan nar datorn har jobbat fardigt testa med slocate alsaconf
"When you know Slackware, you know Linux... when you know Red Hat, all you know is Red Hat."
- http://en.wikipedia.org/wiki/Slackware
aka amWaW @ forum.slackware.se

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 21:26

den hittade ingenting med alsaconf :( ...

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 29 August 2005, 21:37

alsaconf skall köras som root.
The more linux u go, The slacker u get

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 21:39

den hittar inte kommandot mer för det :)

eni
Posts: 129
Joined: 27 August 2005, 00:10

Post by eni » 29 August 2005, 22:09

hehe..alltsa..det har ar typiskt for "enkla" distar...att det ar fan svarare att fa igang saker an med normala distar(las slackware,debian,gentoo)...
ett tips...byt dist..=)
eller sa kan du testa att installera om alsa-utils..=)
"When you know Slackware, you know Linux... when you know Red Hat, all you know is Red Hat."
- http://en.wikipedia.org/wiki/Slackware
aka amWaW @ forum.slackware.se

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 22:13

hehe kanske är så.. men tycker ju ändåså att det borde gå att få igång allt som det ska med tanke på att ubuntu är baserat på debian... och allt hittils har fungerar perfekt med debian paket osv...

Mja jag vet inte om jag orkar byta dist... har nyss vant mig vid ubuntu och fått ordning på "allt" (förutom det jag har problem med)..

Sen använder jag denna dator endast till webbrowsning, IRC och MSN,,,

Har ju min windows dator precis brevid... och den används nästan enbart till musik... och ändå får man bluescreen lite då och då :D ...

Äh jag får väl helt enkelt leva med det här tills jag får nog :lol:
Har faktiskt prövat att instalera debian ett par ggr men fick det aldrig att fungera med swap osv...

phm
Posts: 778
Joined: 17 June 2005, 00:29

Post by phm » 29 August 2005, 22:26

eni wrote:... edit: tuxa...hehe..forsok inte tvinga pa folk det dar kassa FC4..ingen vill ha det iaf..=)
Nope, behöver inte tvinga, folk fattar till slut själva. :D

T ex har FC4 inga problem med ljudet !!! :lol:

eni
Posts: 129
Joined: 27 August 2005, 00:10

Post by eni » 29 August 2005, 22:38

hehe..=)
de flesta brukat fa igang ljudet da de hittar alsaconf och alsamixer..ev ny kernel=)
"When you know Slackware, you know Linux... when you know Red Hat, all you know is Red Hat."
- http://en.wikipedia.org/wiki/Slackware
aka amWaW @ forum.slackware.se

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 29 August 2005, 22:40

Klart att du kan få det att fungera.
Börja med att posta din /etc/modprobe.conf (om du inte har 2.6 kernel så heter den /etc/modules.conf).
sedan 'lsmod'
samt 'lspci|grep audio'
Om du inte vill kladda allt här så kan du pm:a dom till mej.
Hittade orginalrutiner till det kortet.
http://www.epox.nl/downloads/download.p ... oad_id=357
Men jag tycker ofta att alsa funkar bättre än orginal rutinerna.
Last edited by Nille_kungen on 29 August 2005, 22:42, edited 1 time in total.
The more linux u go, The slacker u get

phm
Posts: 778
Joined: 17 June 2005, 00:29

Post by phm » 29 August 2005, 22:41

Lucif3r wrote:...Mja jag vet inte om jag orkar byta dist... har nyss vant mig vid ubuntu och fått ordning på "allt" (förutom det jag har problem med)..
Men hur ska du då finna ut andra distars fördelar ?

Lucif3r
Posts: 52
Joined: 27 June 2004, 17:04

Post by Lucif3r » 29 August 2005, 22:50

aha ok... då ska vi se.. modules:
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

ide-cd
ide-disk
ide-generic
lp
mousedev
psmouse
nvidia
lsmod:
Module Size Used by
ipv6 229504 6
proc_intf 4100 0
freq_table 4100 0
cpufreq_userspace 4572 0
cpufreq_ondemand 6172 0
cpufreq_powersave 1920 0
video 16260 0
sony_acpi 6280 0
pcc_acpi 11264 0
button 6800 0
battery 10244 0
container 4608 0
ac 4996 0
af_packet 20744 2
tsdev 7488 0
via_rhine 19972 0
mii 4736 1 via_rhine
snd_via82xx 25248 3
snd_ac97_codec 64608 1 snd_via82xx
snd_pcm_oss 47652 1
snd_mixer_oss 16768 2 snd_pcm_oss
snd_pcm 84872 3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_timer 23300 1 snd_pcm
snd_page_alloc 9604 2 snd_via82xx,snd_pcm
snd_mpu401_uart 7168 1 snd_via82xx
snd_rawmidi 22944 1 snd_mpu401_uart
snd_seq_device 8332 1 snd_rawmidi
snd 50276 11 snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 9824 3 snd
i2c_viapro 7436 0
i2c_core 21264 1 i2c_viapro
usbhid 29376 0
ehci_hcd 29444 0
uhci_hcd 30224 0
usbcore 107384 4 usbhid,ehci_hcd,uhci_hcd
pci_hotplug 30512 0
via_agp 9216 1
analog 10784 0
gameport 4608 2 snd_via82xx,analog
floppy 54864 0
pcspkr 3816 0
rtc 12216 0
evdev 9088 0
md 43856 0
dm_mod 53116 1
capability 5000 0
commoncap 7808 1 capability
nvidia 3923388 12
agpgart 31784 2 via_agp,nvidia
psmouse 19336 0
mousedev 11160 1
parport_pc 34372 1
lp 10792 0
parport 33480 2 parport_pc,lp
ide_cd 38532 0
cdrom 36508 1 ide_cd
ext3 120968 1
jbd 54168 1 ext3
ide_generic 1664 0
via82cxxx 12956 1
ide_disk 18176 3
ide_core 118988 4 ide_cd,ide_generic,via82cxxx,ide_disk
unix 26164 820
thermal 13576 0
processor 22708 1 thermal
fan 4612 0
fbcon 34048 0
font 8448 1 fbcon
bitblit 5120 1 fbcon
vesafb 6948 0
cfbcopyarea 3968 1 vesafb
cfbimgblt 3072 1 vesafb
cfbfillrect 3584 1 vesafb
lspci|grep audio:
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

Mja det va väl allt tror jag...
ajuste prövade instalera dom där drivrutinerna du länkade och fick följade medelande under ./configure
checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
har fått det på fler installationer... Hur kan man lösa det?

EDIT: löste det men nu står det "configure: error: You have built-in ALSA in your kernel."...

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 29 August 2005, 23:20

Strunta i den drivrutinen i länken alsa stödjer ditt kort.
Testa lägg till följande i /etc/modules.conf (vet inte on detta behövs då den laddar allt).
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-via82xx
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

kör sedan en update-modules
Testa sedan om det blir bättre lr inte?
Kolla oxå hur det ser ut i .asoundrc
om du inte har den så skapa den i din hemkatalog (min ligger i /etc/.asoundrc)
den borde se ut minst som detta
pcm.via82xx {
type hw
card 0
}

ctl.via82xx {
type hw
card 0
}
denna filen kan kompliteras med mixer och slave för att köra massa ljud samtidigt.

Här kommer lite länkar.

http://www.alsa-project.org/alsa-doc/do ... le=via82xx
http://www.alsa-project.org/alsa-doc/al ... cm_plugins
Den översta är hur du kompilerar samt ställer in ditt kort (kompilera behöver du inte).
Den andra är hur du ställer in mixer och slave.
Men ditt dåliga ljud kan oxå vara att den laddar en modul som inte skall vara med (inbyggda codecs laddar ofta ett modem med som knasar ljudet, den får man då svartlista i /etc/hotplug/blacklist )
Men då jag själv inte kör via chip så e det inte min vassasde sida.
The more linux u go, The slacker u get

Post Reply