Installera java för Bankid

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
User avatar
drhex
Posts: 163
Joined: 29 December 2004, 22:05
Location: Knivsta

Installera java för Bankid

Post by drhex » 18 February 2009, 22:14

Någon som har lyckats få igång det nya "säkerhetsprogrammet" för bankid som numera ska finnas för Linux?
Jag fastnar på installationen av Java. På bankid sida (https://install.bankid.com/Information____43.aspx) påsås att:

"I Ubuntu Linux kan du också hämta Sun Java med hjälp av den inbyggda hanteraren för ny programvara."

När jag tittar med Synaptic Package Manager så är sun-java6-jre redan installerat och Java är enablat enligt preferences-sidorna i Firefox.
Det dög tydligen inte för Bankid, som skickade mig till Sun's sidor för att ladda ned java.
Sun anser att jag har "Version 6 Update 10" och borde byta till "Version 6 Update 12". Denna version kunde jag förvisso ladda ner och packa upp, men hur får man sedan in den i Firefox? Deras hjälpfiler verkar tro att "Firefox 1.5" är en ny version...

User avatar
kjell-e
Posts: 2817
Joined: 21 December 2002, 16:27
Location: Linköping
Contact:

Re: Installera java för Bankid

Post by kjell-e » 19 February 2009, 15:54

Du behöver libflashplayer.so i plugins-katalogen till din firefox. Om du t.ex. har firefox 3.0.6 i /usr/lib/firefox-3.0.6/ så ska du ha en fil eller länk i /usr/lib/firefox-3.0.6/plugins/

Jag har en symbolisk länk i plugins-katalogen: libflashplayer.so -> /usr/lib/flash-plugin/libflashplayer.so
Det går att åstadkomma med:

Code: Select all

ln -s /usr/lib/flash-plugin/libflashplayer.so /usr/lib/firefox-3.0.6/plugins/
Notera att du lär behöva vara root och att jag här förutsätter att du har libflashplayer.so i katalogen /usr/lib/flash-plugin. I Ubuntu som du kör kan du lägga till sudo först på kommandoraden.

User avatar
drhex
Posts: 163
Joined: 29 December 2004, 22:05
Location: Knivsta

Re: Installera java för Bankid

Post by drhex » 19 February 2009, 17:27

Ska man länka in flashplayer för att få java att funka? :-?
Återkommer när jag testat mer, det kanske bara är filnamnen som är lustiga. Den länk till java-plugin som jag redan har säger sig vara en firefox-special. Hoppas det fungerar även med en "allmän" java.

erik_persson
Posts: 1474
Joined: 29 August 2002, 15:19

Re: Installera java för Bankid

Post by erik_persson » 19 February 2009, 18:24

drhex wrote:Någon som har lyckats få igång det nya "säkerhetsprogrammet" för bankid som numera ska finnas för Linux?
Jag fastnar på installationen av Java. På bankid sida (https://install.bankid.com/Information____43.aspx) påsås att:

"I Ubuntu Linux kan du också hämta Sun Java med hjälp av den inbyggda hanteraren för ny programvara."

När jag tittar med Synaptic Package Manager så är sun-java6-jre redan installerat och Java är enablat enligt preferences-sidorna i Firefox.
Det dög tydligen inte för Bankid, som skickade mig till Sun's sidor för att ladda ned java.
Sun anser att jag har "Version 6 Update 10" och borde byta till "Version 6 Update 12". Denna version kunde jag förvisso ladda ner och packa upp, men hur får man sedan in den i Firefox? Deras hjälpfiler verkar tro att "Firefox 1.5" är en ny version...
Installera java och sedan flash via ubuntus pakethanterare. Jag har för mig att det är full tillräckligt.

/erik

User avatar
drhex
Posts: 163
Joined: 29 December 2004, 22:05
Location: Knivsta

Re: Installera java för Bankid

Post by drhex » 19 February 2009, 22:52

Bankid-siten nämner ingenting om flash. Den version av java man får via apt-get var inte tillräcklig. Det hjälpte dock att ladda ner senaste versionen från Sun och göra:

Code: Select all

cd /usr/lib/firefox/plugins
ln -s /usr/java/jre1.6.0_12/plugin/i386/ns7/libjavaplugin_oji.so libjavaplugin.so
Lite konstigt känns det dock att byta ut en plugin ämnad för firefox mot en som verkar vara gjord för netscape. Men Bankid-siten klagade iallafall inte längre. :)

vfr
Posts: 186
Joined: 18 November 2006, 18:05

Re: Installera java för Bankid

Post by vfr » 20 February 2009, 10:40

Lite konstigt känns det dock att byta ut en plugin ämnad för firefox mot en som verkar vara gjord för netscape

Det kanske det kan göra vid första påseende. Dock är det ju så att både Firefox och Netscape bygger på Mozillakodbasen så saker är väldigt kompatibla "på djupet", trots allt.

erik_persson
Posts: 1474
Joined: 29 August 2002, 15:19

Re: Installera java för Bankid

Post by erik_persson » 20 February 2009, 22:02

drhex wrote:Bankid-siten nämner ingenting om flash. Den version av java man får via apt-get var inte tillräcklig. Det hjälpte dock att ladda ner senaste versionen från Sun och göra:

Code: Select all

cd /usr/lib/firefox/plugins
ln -s /usr/java/jre1.6.0_12/plugin/i386/ns7/libjavaplugin_oji.so libjavaplugin.so
Lite konstigt känns det dock att byta ut en plugin ämnad för firefox mot en som verkar vara gjord för netscape. Men Bankid-siten klagade iallafall inte längre. :)
Du ska installera sun-java! Inte någon annan java.
ex:
apt-get install sun-java6-jre
apt-get install sun-java6-plugin

/erik

User avatar
drhex
Posts: 163
Joined: 29 December 2004, 22:05
Location: Knivsta

Re: Installera java för Bankid

Post by drhex » 20 February 2009, 22:31

Det var vad jag också hade hoppats på. De båda paketen du nämner hade jag redan installerade, men det var inte tillräckligt. Bankid-siten säger "Ej OK" i sitt java-test då den senaste versionen man kan hämta med apt-get är 6.10 medan det tydligen är 6.12 som krävs.

erik_persson
Posts: 1474
Joined: 29 August 2002, 15:19

Re: Installera java för Bankid

Post by erik_persson » 20 February 2009, 23:41

drhex wrote:Det var vad jag också hade hoppats på. De båda paketen du nämner hade jag redan installerade, men det var inte tillräckligt. Bankid-siten säger "Ej OK" i sitt java-test då den senaste versionen man kan hämta med apt-get är 6.10 medan det tydligen är 6.12 som krävs.
Underligt. Jag har 6.10 och det fungerar bra med bankid (http://www.bankid.com/ och https://test.bankid.com/).

/erik

tuxor
Posts: 2
Joined: 2 March 2009, 14:29

Re: Installera java för Bankid

Post by tuxor » 2 March 2009, 14:52

Jag hade också problem med att installera programvaran för BankID (Nexus Personal) p g a fel java version (6 update 10) enligt installationsprogrammet.

Lyckades dock få ordning på det till slut utan att behöva uppgradera java. (Vilket jag inte rekommenderar att göra utanför Synaptic eftersom man kan få det ganska struligt med uppdateringarna av java efter det.)

Vet ej riktigt vad som gjorde det, men följande åtgärder gjorde jag:
- Gick in på https://test.bankid.com/ och gjorde testen där - funkade. (Kör en java applet i Firefox, dock visas ju inget bankid i dropplistan eftersom man inte har det ännu.)
- Uppdaterade flash till senaste version (flashplugin-nonfree / 10.0.22.87ubuntu1~intrepid1). (Ja, det är mysko. Vet inte om det har/hade någon påverkan, för det borde inte påverka java eller BankID.)
- Startade om datorn.
- Gick till min internetbank och beställde ett bankid. Installerade i den processen Nexus personal för Linux.
- Prövade att beställa ett bankid efter installationen av Nexus. Gick inte, då bankid:t levererades till min hårddisk utan certifikat.
- Startade om datorn.
- Prövade igen att beställa ett bankid. Fick återigen ett par gånger bankid:n utan certifikat. Men efter c:a tre försök så fungerade det.

Mycket glädjande att man kan köra bankid på linux numera.

Ubuntu 8.10 / Kernel 2.6.27-11-generic / Firefox 3.0.6

cowlol
Posts: 25
Joined: 9 February 2009, 09:57

Re: Installera java för Bankid

Post by cowlol » 3 March 2009, 20:48

För att java skall funka med bankid så måste man ha java6 core och mozilla pluginnet, båda finns i debians/ubuntus utbud.

Post Reply