(Löst) åäö-filer på monterad HD

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
Jax
Posts: 22
Joined: 3 September 2003, 23:23

(Löst) åäö-filer på monterad HD

Post by Jax » 6 September 2003, 00:34

Jag kör Red Hat 9 och har monterat mina windows hårddiskar för att först och främst kunna spela den musiken som ligger på dem.

Problemet är att Red Hat inte tycker om de filerna som har å,ä eller ö i sitt filnamn. Filen "nationalsången.txt" har t.ex. fått namnet "Nationals?ngen.txt (ogiltig Unicode)" och går inte att öppna. Vad ska jag göra för att fixa det? Jag vill helst inte döpa om alla mina filer.
Last edited by Jax on 6 September 2003, 20:24, edited 1 time in total.
Praeparatus Supervivet

napalm
Posts: 91
Joined: 29 November 2002, 21:17
Location: Luleå

Post by napalm » 6 September 2003, 07:13

Jag har lagt till information om teckenuppsättning och codepage i /etc/fstab. Exempelvis så här:
/dev/hda1 /fat-c vfat defaults,iocharset=iso8859-1,codepage=437 1 0
Klient: Ubuntu Linux
Server: FreeBSD
#227711 http://counter.li.org

Jax
Posts: 22
Joined: 3 September 2003, 23:23

Post by Jax » 6 September 2003, 10:00

Jag provade det och skrev såhär i fstab:

Code: Select all

/dev/hda1	/mnt/c			vfat	defaults,iocharset=iso8859-1,codepage=437	1 1
/dev/hda5	/mnt/d			ntfs	defaults,iocharset=iso8859-1,codepage=437	1 1
Men det ville sig inte. Den andra hårddisken ville inte bli monterad överhuvudtaget, medans den första blev det, men åäö fungerade ändå inte. Jag har ntfs stöd och följande har fungerat för monterande innan (förutom åäö-filer).

Code: Select all

/dev/hda1	/mnt/c			vfat	defaults	1 1
/dev/hda5	/mnt/d			ntfs	defaults	1 1
Kan jag inte ha samma tal efter codepage? Och har jag skrivit något mer fel som gör att åäö inte fungerar?
Praeparatus Supervivet

OErjan
Posts: 1834
Joined: 21 April 2003, 06:43
Location: 64*N 21*E

Post by OErjan » 6 September 2003, 10:10

defaults och det du lade till kan ge konflikter om jag mins rätt.
prova

Code: Select all

 /dev/hda1   /mnt/c         vfat   users,gid=users,umask=0002,iocharset=iso8859-1,code=437
det ger nästan alla full tillgång till din hdd. ändra umask enligt vad du vill att det ska vara. borde funka.
Last edited by OErjan on 6 September 2003, 10:13, edited 1 time in total.

OErjan
Posts: 1834
Joined: 21 April 2003, 06:43
Location: 64*N 21*E

Post by OErjan » 6 September 2003, 10:12

även users... kan behöva ändras förstås

Getrb
Posts: 1150
Joined: 28 October 2002, 17:26
Location: Trollhättan
Contact:

Post by Getrb » 6 September 2003, 10:14

NTFS bör du inte skriva till från Linux.
Och ang. åäö..... det finns spaltkilometer om detta tidigare i forumet.

Dvs. http://bbs.linux.se/search.php är att rekommendera ;-)

OErjan
Posts: 1834
Joined: 21 April 2003, 06:43
Location: 64*N 21*E

Post by OErjan » 6 September 2003, 10:34

joo, du har rätt Getrb, men jag chansar ändå på min dator (XP...) antivirusen gnälle var gång jag startar XP men ingen krash hitills, om det krashar gråter jag inte mycket. jag har inte mycket tid i XP på denhär burken, 2timmar eller så, m.a.o. åker XP snart ut till fördel för Debian.

Jax
Posts: 22
Joined: 3 September 2003, 23:23

Post by Jax » 6 September 2003, 10:36

Ber om ursäkt för att jag inte sökte först, men jag fortsätter att fråga i den här tråden eftersom det inte fungerar ändå.

Har prövat det som har stått tidigare i denna tråden plus detta allra senast:

Code: Select all

/dev/hda1	/mnt/c		vfat	iocharset=iso8859-15,user,exec,auto,codepage=850,nodev,rw 1 0
/dev/hda5	/mnt/d		ntfs	iocharset=iso8859-15,user,exec,auto,codepage=850,nodev,rw 1 0
Men det ger exakt samma fel. c hårddisken klarar fortfarande inte åäö och d vill inte bli monterad. Står något om att jag har felaktigt filsystem eller felaktig parameter. Då mitt ntfs stöd har fungerat utmärkt tidigare så tycker jag att det inte borde vara det som spökar.

Några mer förslag på vad jag kan pröva?
Vad betyder de två sista siffrorna? Alla verkar ju skriv olika, 0 0, 0 1 eller 1 1. Spelar det någon roll?
Praeparatus Supervivet

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 6 September 2003, 13:25

Om du använder UTF-8 locale kan du prova:

Code: Select all

/dev/hda1   /mnt/c      vfat   iocharset=utf8,user,exec,auto,codepage=850,nodev,rw 1 0
/dev/hda5   /mnt/d      ntfs   iocharset=utf8,user,exec,auto,nodev,rw 1 0 
/Mikael

Johansson
Posts: 199
Joined: 3 April 2002, 02:00
Location: Sölvesborg

Post by Johansson » 6 September 2003, 14:56

Jax wrote:Vad betyder de två sista siffrorna? Alla verkar ju skriv olika, 0 0, 0 1 eller 1 1. Spelar det någon roll?
Näst sista siffran behöver du inte bry dig om ifall du inte använder dig av backup.
Sista siffran används av fsck (file system check) för att se i vilken ordning partionerna skall bli kollade vid uppstarten.Root brukar ha siffran ett.Om det är en nolla så sker ingen kontroll.

Jax
Posts: 22
Joined: 3 September 2003, 23:23

Post by Jax » 6 September 2003, 16:51

mikma wrote:Om du använder UTF-8 locale kan du prova:

Code: Select all

/dev/hda1   /mnt/c      vfat   iocharset=utf8,user,exec,auto,codepage=850,nodev,rw 1 0
/dev/hda5   /mnt/d      ntfs   iocharset=utf8,user,exec,auto,nodev,rw 1 0 
/Mikael
Vad är UTF-8 locale och hur vet jag om jag använder det?
Praeparatus Supervivet

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 6 September 2003, 19:52

Skriv "locale" i en konsol. Du ser vilket kodningssystem som din locale har på variablernas avslutning. De vanligaste i Sverige är ISO-8859-1 (Latin1), ISO-8859-15 (som Latin1, men har euro-symbol) eller UTF-8 (Unicode). I RedHat 9 används UTF-8 som standard om man inte bytt. Du kan söka i forumet om du vill byta till ISO-8859-1 eller ISO-8859-15.
/Mikael

Jax
Posts: 22
Joined: 3 September 2003, 23:23

Post by Jax » 6 September 2003, 20:23

mikma wrote:Om du använder UTF-8 locale kan du prova:

Code: Select all

/dev/hda1   /mnt/c      vfat   iocharset=utf8,user,exec,auto,codepage=850,nodev,rw 1 0
/dev/hda5   /mnt/d      ntfs   iocharset=utf8,user,exec,auto,nodev,rw 1 0 
/Mikael
Det fungerade alldelese utmärkt. Tack så mycket.
Praeparatus Supervivet

Post Reply