Vad betyder: VARNING: Följande paket kunde inte autentiseras

Här skriver vi våran FAQ. Vill du komma med förslag, skriva själv eller rätta stavfel så gör det här. Någorlunda färdiga frågor komer att läggas i forumet FAQ.
Post Reply
emj
Posts: 23
Joined: 2 October 2007, 17:32

Vad betyder: VARNING: Följande paket kunde inte autentiseras

Post by emj » 28 August 2008, 08:46

Detta är första utkastet och jag tänker förbättre detta framåt, men eftersom jag inte har koll åp hurman ska fixa det egentligen så får ni jättegärna komma med insikter.

När man installerar eller uppdaterar paket på Ubuntu och Debian kan man få detta fel, som hindrar en att uppdatera:
VARNING: Följande paket kunde inte autentiseras!
Detta är ett ganska allvarligt säkerhets problem. Om du installerar paket som inte har autentiseras så kan du mycket väl installera en lösenordstjuvlyssnare från någon ond hacker, eller kanske är det din kompis som har lyckats byta ut paketen för att "root:a" din burk.

Det du behöver kontrollera;
1. var du laddar hem dina paket från? prova att byt från Sverige servern, till huvudservern. Via "System -> Administration -> Programvarukällor -> Programvara från Ubuntu:"
2. att du har säkerhetsnycklar från Ubutnu: mha Menyvalet "System -> Administration -> Programvarukällor -> Autentisering"

Code: Select all

admin@exempel:~$ sudo apt-get upgrade
Läser paketlistor... Färdig
Bygger beroendeträd         
Läser tillståndsinformation... Färdig
Följande paket har hållits tillbaka:
  linux-generic linux-headers-generic linux-image-generic
  linux-restricted-modules-generic
Följande paket kommer att uppgraderas:
  eject libartsc0 linux-headers-2.6.24-19 linux-headers-2.6.24-19-generic
  linux-image-2.6.24-19-generic linux-libc-dev linux-restricted-modules-common
  pciutils
8 uppgraderade, 0 nyinstallerade, 0 att ta bort och 4 ej uppgraderade.
Behöver hämta 28,2MB arkiv.
Efter denna åtgärd kommer ytterligare 0B diskutrymme att användas.
Vill du fortsätta [J/n]? 
VARNING: Följande paket kunde inte autentiseras!
  linux-image-2.6.24-19-generic eject pciutils libartsc0
  linux-headers-2.6.24-19 linux-headers-2.6.24-19-generic linux-libc-dev
  linux-restricted-modules-common
Installera dessa paket utan verifiering [j/N]? n
E: Några av paketen kunde inte autentiseras

För det mesta när man får ett felmeddelande så är det bra att köra programmet på Engelska, eftersom det är fler som rapporterar engelska felmeddelanden. Det kan du göra genom;
1. att logga ut
2. tryck på inställningar vid inloggnings fönstret
3. ställ in Engelska
4. logga in
5. kör programmet igen och sök efter det engelska meddelandet.

Post Reply