DC++ till Linux

Har du något? Posta då här.
User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

DC++ till Linux

Post by Biffy » 7 May 2006, 17:59

Ville bara dela med mig av en upptäckt jag gjort. :)

Ni vet ju att det finns en DC++ klient till Linux. Den finns att ladda ner som CVS här:

http://linuxdcpp.berlios.de/

Det kom en ny CVS i förrgår (5 maj 2006) så se till så du har den senaste.

Problemet med ldcpp (Linux dc++) är att den krashar. En hel del. Den gör det för mig och det finns andra med samma problem. Ibland gör den det utan vidare, ibland gör den det när klienten får jobba en del, och det mest märkbara är att den gör det när man kommer in i en hub. Det sistnämda händer bara ibland och har tydligen något att göra med om folk i huben har konstiga tecken i sina namn. Ytterst frustrerande.

Jag skickade in en bugrapport till tillverkarna och fick väldigt snabbt tipset att pröva "Naga's branch" . Det är ldcpp, men med nyare kod. Den fungerar klart stabilare åtminstone för mig. För att klargöra, det är fortfarande dcpp och allt ser (i princip) likadant ut. Det är en build för version 0.689 av DC++. Kolla Naga's sida här:

http://ldcpp.dx.homelinux.org/ldcpp

För att ladda hem och installera Naga's branch gör såhär:

1) Jag blev varnad om att köra en backup på vissa filer då Naga's branch tydligen skriver över queuen bla. Så kör en backup på dina inställningar. Detta görs genom att säkerhetskopiera .dc++ som ligger i din hemkatalog. Exempel:

cp -a /home/pelle/.dc++ /home/pelle/.dc++_backup

2) När det är klart är det dags att hämta sourcen. Detta görs lite annorlunda dock. Istället för att köra CVS används "Subversion" . Se till att installera subversion.

3) När subversion är installerat, ställ dig där du vill att Naga's branch ska hamna. Tex cd /home/pelle/downloads

4) När du står i katalogen där du vill ha Naga's branch, kör:

Code: Select all

svn co http://ldcpp.dx.homelinux.org/svn/ldcpp/branches/0.68-client/src/
När det är klart ska det finnas en katalog som heter "src" , gå in i den.

5) Nu skriver du:

Code: Select all

scons debug=1
6) Klart! Kör igång programmet med

Code: Select all

./ldcpp
Om du tycker att vanliga dcpp fungerar bra så är det väl ingen mening med att krångla med två olika versioner, men är du missnöjd med vanliga dcpp så testa gärna Naga's branch!
Image

Använder Ubuntu Dapper.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 7 May 2006, 19:31

Tack för detta!
Men det vill inte riktigt.

Code: Select all

emil@Megaleif ~/ldcpp/src $ scons debug=1
scons: Reading SConscript files ...
Checking for g++ >= 3.4...ok
Checking for pkg-config... ok
Checking for gtk+-2.0 >= 2.6... failed
gtk+ >= 2.6 not found.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
ronin
Posts: 887
Joined: 6 July 2002, 17:46

Post by ronin » 7 May 2006, 20:29

sudo apt-get install libgtk2.0-dev

Borde lösa det problemet.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 7 May 2006, 23:11

ronin wrote:sudo apt-get install libgtk2.0-dev

Borde lösa det problemet.
Det gjorde det! Tack! :)
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 8 May 2006, 21:46

Emil.s wrote:
ronin wrote:sudo apt-get install libgtk2.0-dev

Borde lösa det problemet.
Det gjorde det! Tack! :)
Har du haft problem med den vanliga versionen eller ville du bara testa?
Image

Använder Ubuntu Dapper.

xarator
Posts: 202
Joined: 22 August 2005, 19:00
Location: Skelleftea

Post by xarator » 8 May 2006, 21:53

Linuxdcpp funkar relativt bra men det är ganska jobbigt med att det hänger sig lite då och då.
har haft stora problem främst med indexeringsprocessen. Den ominderxerar massa filer hela tiden och den krashar om indexeringsprocessen inte visas.
Enda gångerna det kraschar för mig är iaf vid indexering( som den har tendens att köra hela tiden)

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 8 May 2006, 21:54

Biffy wrote:
Emil.s wrote:
ronin wrote:sudo apt-get install libgtk2.0-dev

Borde lösa det problemet.
Det gjorde det! Tack! :)
Har du haft problem med den vanliga versionen eller ville du bara testa?
Inga problem vad jag visste. Men i nya så kunde jag plötsligt se alla fält när man kollar på "Publik hubs". Var något mer också. Men från början så var det nyfikenhet. ;)

Gillar att ha det senaste. Denna DC++, beta azureus, cvs Amsn och så Dapper drake osv. :D
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 8 May 2006, 22:39

Emil.s wrote:Gillar att ha det senaste. Denna DC++, beta azureus, cvs Amsn och så Dapper drake osv. :D
Ja, om det funkar tillfredställande så är det härligt med dev.
Image

Använder Ubuntu Dapper.

User avatar
Vampis
Posts: 936
Joined: 30 December 2004, 12:19
Location: Kållered
Contact:

Post by Vampis » 9 May 2006, 08:36

Tackar för en mycket bra tillvägagångs-beskrivning =)

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 9 May 2006, 17:23

Vampis wrote:Tackar för en mycket bra tillvägagångs-beskrivning =)
Tackar! :) Jag var lite stressad när jag skrev det, gött att det blev bra.
Image

Använder Ubuntu Dapper.

Iljitj
Posts: 6
Joined: 5 September 2005, 21:08

Post by Iljitj » 11 May 2006, 22:37

Fan vad bra, det andra kraschade ju var tionde minut;D

Iljitj
Posts: 6
Joined: 5 September 2005, 21:08

Post by Iljitj » 16 May 2006, 20:01

När jag trycker på "Add Folder" under sharefliken så händer det inget och jag får detta meddelandet i terminalen:

(ldcpp:6150): Gtk-CRITICAL **: gtk_dialog_run: assertion `GTK_IS_DIALOG (dialog)' failed

(ldcpp:6150): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed


vad kan detta bero på?
jag har gtk 2.6.7

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 16 May 2006, 21:11

Iljitj wrote:När jag trycker på "Add Folder" under sharefliken så händer det inget och jag får detta meddelandet i terminalen:

(ldcpp:6150): Gtk-CRITICAL **: gtk_dialog_run: assertion `GTK_IS_DIALOG (dialog)' failed

(ldcpp:6150): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed


vad kan detta bero på?
jag har gtk 2.6.7
Samma för mig. Skulle precis skriva...
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

_daniel_
Posts: 78
Joined: 22 April 2003, 13:37

Post by _daniel_ » 16 May 2006, 22:06

måste bara flika in och säga att sedan jag uppdaterat till senaste cvs:en av linuxdcpp (vanliga branchen) så har det inte kraschat en gång. tidigare kraschade det nån gång om dagen, speciellt om man sökte efter grejer och laddade ner och höll på. lämnade man det bara ifred brukade det iofs hålla sig lugnt, men nu klarar jag tom av att utnyttja dc-protokollet för egen vinning

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 17 May 2006, 17:31

Iljitj wrote:När jag trycker på "Add Folder" under sharefliken så händer det inget och jag får detta meddelandet i terminalen:

(ldcpp:6150): Gtk-CRITICAL **: gtk_dialog_run: assertion `GTK_IS_DIALOG (dialog)' failed

(ldcpp:6150): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed


vad kan detta bero på?
jag har gtk 2.6.7
Det fungerar här. Skumt! Jag kör Ubuntu Dapper.
Image

Använder Ubuntu Dapper.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 17 May 2006, 21:52

Biffy wrote:
Iljitj wrote:När jag trycker på "Add Folder" under sharefliken så händer det inget och jag får detta meddelandet i terminalen:

(ldcpp:6150): Gtk-CRITICAL **: gtk_dialog_run: assertion `GTK_IS_DIALOG (dialog)' failed

(ldcpp:6150): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed


vad kan detta bero på?
jag har gtk 2.6.7
Det fungerar här. Skumt! Jag kör Ubuntu Dapper.
Jag med... :roll:
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
mucha
Posts: 150
Joined: 5 October 2002, 11:58
Location: Östhammar

Post by mucha » 18 May 2006, 20:22

ronin wrote:sudo apt-get install libgtk2.0-dev

Borde lösa det problemet.
Får samma fel vid scons debug=1 men funkar inte även fast jag installerat libgtk2.0-dev från apt. Jag kör ubuntu dapper.
Image

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 19 May 2006, 04:38

Jag kör inte dom senaste för dessa krashar så ofta har även testat Naga's branch.
Jag kör sena från 2005 eller tidig 2006 då dessa är klart stabilast.
Dom senare krashar innan den äns startat ibland.
Medans dom gamla kan stå igång i flera dygn.

Men jag kör på slackware med och har inte gnome installerat utan bara gtk libbarna.
The more linux u go, The slacker u get

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 19 May 2006, 19:10

Nille_kungen wrote:Jag kör inte dom senaste för dessa krashar så ofta har även testat Naga's branch.
Jag kör sena från 2005 eller tidig 2006 då dessa är klart stabilast.
Dom senare krashar innan den äns startat ibland.
Medans dom gamla kan stå igång i flera dygn.

Men jag kör på slackware med och har inte gnome installerat utan bara gtk libbarna.
Jag har läst detta också, att dom gamla debarna som spreds på internet är faktiskt dom stabilaste, förutom att dom (för mig) kraschade när man gick in i hubarn ibland. Detta var en bug som dock är löst i Nagas branch (vad jag vet) för Naga's branch går bra här.
Image

Använder Ubuntu Dapper.

Poka
Posts: 54
Joined: 22 March 2004, 21:21
Location: Gävle

Post by Poka » 21 May 2006, 14:14

Får detta för varje fil som indexeras:

Code: Select all

Thrown: FileException: Bad file descriptor (/home/peter/.dc++/HashIndex.xml.tmp)

User avatar
Ekensten
Posts: 37
Joined: 19 March 2006, 17:13
Location: Lidköping
Contact:

Post by Ekensten » 23 May 2006, 17:21

Yahoo? Det var minst ligga buggigt om inte buggigare... buggar ur ibland då jag ska söka, eller connecta.... otroligt irreterande.
LFS 6.4, 2.6.28.7 samt Debian Lenny amd64, 2.6.28.7

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 23 May 2006, 19:00

Ekensten wrote:Yahoo? Det var minst ligga buggigt om inte buggigare... buggar ur ibland då jag ska söka, eller connecta.... otroligt irreterande.
Konstigt, Naga's branch fungerar som en klocka här. Undrar varför det är så individuellt.
Image

Använder Ubuntu Dapper.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 3 June 2006, 23:55

Jag tänkte tesa igen nu. Verkar uppdateras ganska ofta. :)
Men jag ser att det finns en massa patchar.

Men hur installerar man dem?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 3 June 2006, 23:57

Mer problem...

Code: Select all

emil@Megaleif ~/ldcpp/src $ scons debug=1

scons: *** No SConstruct file found.
File "/usr/lib/python2.4/site-packages/SCons/Script/__init__.py", line 870, in _main
Vad nu då!?

EDIT:
Löste det! Laddade ner nyaste releasen. "svn co http://ldcpp.dx.homelinux.org/svn/ldcpp/tags/0.69-r1".

Men:

Code: Select all

emil@Megaleif ~/0.69-r1 $ scons
scons: Reading SConscript files ...
Checking for g++ >= 3.4...ok
Checking for pkg-config... ok
Checking for gtk+-2.0 >= 2.6... failed
gtk+ >= 2.6 not found.
Och nu är ju libgtk2.0-dev installerat. :-?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Poka
Posts: 54
Joined: 22 March 2004, 21:21
Location: Gävle

Post by Poka » 7 June 2006, 23:28

Emil.s, jag fick samma fel, fick installera:
libglitz
alla varianter som finns när du söker på det installerade jag iaf :)

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 7 June 2006, 23:39

Ja just, har glömt att säga att att 0.69 är den nya versionen som gäller nu. Har själv inte testat den då min installation av 0.689 funkar bra.

Det enda jag kan klaga på är att GUI:et är lite slött på nåt sätt.
Image

Använder Ubuntu Dapper.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 8 June 2006, 08:58

Poka wrote:Emil.s, jag fick samma fel, fick installera:
libglitz
alla varianter som finns när du söker på det installerade jag iaf :)
libglitz1-dev löste problemet! Tack så mycket. Komplierar för fullt. :)
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Poka
Posts: 54
Joined: 22 March 2004, 21:21
Location: Gävle

Post by Poka » 9 June 2006, 15:56

försöker få igång detta, men jag får detta felmeddelande:

Code: Select all

client/HashManager.cpp: In member function ‘virtual int HashManager::Hasher::run()’:
client/HashManager.cpp:634: error: no matching function for call to ‘max(long long int, u_int64_t)’
scons: *** [build/client/HashManager.o] Error 1
scons: building terminated because of errors.

Poka
Posts: 54
Joined: 22 March 2004, 21:21
Location: Gävle

Post by Poka » 10 June 2006, 00:11

dessa felmeddelanden dyker upp när jag startar...

Code: Select all

** (dcpp:6637): CRITICAL **: get_label_from_notebook_page: assertion `GTK_IS_WIDGET (child)' failed
dyker upp ett annat meddelande när jag fixar emd settings också...

JAg har försökt med tre versioner och detta problem uppstod när jag försökte installera nagas branch :(

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 10 June 2006, 00:25

Ett tips är ju att fråga på IRC.

#linuxdc++ @ irc.freenode.net

Jag har fått mycket hjälp av en utav utvecklarna. Steven.
Image

Använder Ubuntu Dapper.

Poka
Posts: 54
Joined: 22 March 2004, 21:21
Location: Gävle

Post by Poka » 10 June 2006, 12:31

har fått hjälp en liten förklaring av felet men ingen lösning, det verkar som att felmeddelandet inte härstammar från DC++

Poka
Posts: 54
Joined: 22 March 2004, 21:21
Location: Gävle

Post by Poka » 13 June 2006, 22:04

ingen som vet hur man fixar med patcharna som naga har på sin sida ?

Edit behövdes inte..bara att dra ner sourcen igen, lättare så :)

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 13 June 2006, 22:29

Testade nu. Och nu funkar det perfekt. :D
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 19 June 2006, 19:25

Vill bara säga att Naga's branch nu är "merged" med den vanliga ldcpp. Ladda gärna hem och testa den vanliga. Har själv gjort det. Har dock behållit Naga's branch ifall denna går dåligt. Rätt otestat än.
Image

Använder Ubuntu Dapper.

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 19 June 2006, 23:44

Den nya cvs:en fungerar jättebra och är stabil.
20060616 har jag testat
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 28 June 2006, 22:59

Nu verkar det inte finnas några releaser. Nu verkar det bara finnas "my-playground".
http://ldcpp.dx.homelinux.org/svn/ldcpp ... round/src/

Alltså:

Code: Select all

svn co http://ldcpp.dx.homelinux.org/svn/ldcpp/branches/my-playground/src/
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 28 June 2006, 23:06

Men:

Code: Select all

emil@Megaleif ~/src $ scons
scons: Reading SConscript files ...
Checking for g++ >= 3.4...ok
Checking for pkg-config... ok
Checking for gtk+-2.0 >= 2.6... ok
Checking for gthread-2.0 >= 2.4... ok
Checking for libglade-2.0 >= 2.4... ok
Checking for C header file time.h... yes
Checking for C header file signal.h... yes
Checking for C header file unistd.h... yes
Checking for C header file sys/poll.h... yes
Checking for main() in C library pthread... yes
Checking for main() in C library z... yes
Checking for main() in C library bz2... yes
Checking for PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP in pthread.h... ok
scons: done reading SConscript files.
scons: Building targets ...
gcc -pthread -pthread -I/usr/include/libglade-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libxml2 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -c -o build/gui/eggtrayicon.o linux/eggtrayicon.c
linux/eggtrayicon.c:21:20: fel: config.h: Filen eller katalogen finns inte
linux/eggtrayicon.c: In function "egg_tray_icon_class_init":
linux/eggtrayicon.c:127: error: "GETTEXT_PACKAGE" undeclared (first use in this function)
linux/eggtrayicon.c:127: error: (Varje odeklarerad identifierare rapporteras bara
linux/eggtrayicon.c:127: error: en gång för varje funktion den finns i.)
scons: *** [build/gui/eggtrayicon.o] Error 1
scons: building terminated because of errors.
Någon idé?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 29 June 2006, 02:16

Jag tankar "orginalet" via cvs.
To check out the CVS anonymously:
cvs -d:pserver:anonymous@cvs.linuxdcpp.berlios.de:/cvsroot/linuxdcpp login
(leave password blank)
cvs -z3 -d:pserver:anonymous@cvs.linuxdcpp.berlios.de:/cvsroot/linuxdcpp co linuxdcpp

I en utvecklar version så går det inte att kompilera ibland då ändringen kanske inte är klar och testad än.
Testa om någon dag igen eller testa cvs versionen.
Det har tagit fart i utvecklingen på senare tid.
The more linux u go, The slacker u get

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 12 July 2006, 17:04

Tänkte höra med er andra:

Är det någon av er som känner att dcpp känns lite "unresponsive" och slött ibland? Det är absolut inte så det blir oanvändbart, men det märks.
Image

Använder Ubuntu Dapper.

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 12 July 2006, 19:22

Jo men det värkar som den vaknar sen så jag trodde den skrev minne till swapen men inte orkat kolla om det är så.
The more linux u go, The slacker u get

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 12 July 2006, 22:24

Nille_kungen wrote:Jo men det värkar som den vaknar sen så jag trodde den skrev minne till swapen men inte orkat kolla om det är så.
Så du upplever samma sak?
Image

Använder Ubuntu Dapper.

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 12 July 2006, 23:15

Ja det gör jag framförallt om jag byter skrivbord till det me dc++
Det är inte alltid så men ibland.
Även när man byter tagg inne i dc++ kan det uppstå.
Men det är en beta så det är nog så en stund till.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 12 July 2006, 23:39

Funkar fortfarande inte med Nagas. Ska testa med "orginalet". :P

Hör väl av mig om hur det funkar.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 13 July 2006, 00:05

Jag har även upplevt problem med hashfilen som gjort att den inte startar.
Så fått radera och hasha om.
Hashfilen (HashIndex.xlm) har antagligen blivit förstor över 1.3gb delade ut lite mycket kanske.
Rensade lite share sen fungerade det bra igen.
Men har talat om det för utvecklarna.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 13 July 2006, 00:19

Nille_kungen wrote:Jag har även upplevt problem med hashfilen som gjort att den inte startar.
Så fått radera och hasha om.
Hashfilen (HashIndex.xlm) har antagligen blivit förstor över 1.3gb delade ut lite mycket kanske.
Rensade lite share sen fungerade det bra igen.
Men har talat om det för utvecklarna.
1.3GiB!? Är det möjligt att dela ut så mycket? :P
Min är på 1.3MiB med 29GiB utdelat.

Kan i allafall säga att allt verkar flyta på bra. :)
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 13 July 2006, 00:33

Jag tror att den hashar konstigt efter viss share.
Filen ska inte vara så stor.
Men något gör att den blev det.
När jag testade detta rörde det sig om ca 240gb.
The more linux u go, The slacker u get

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 13 July 2006, 19:01

Nille_kungen wrote:Jag har även upplevt problem med hashfilen som gjort att den inte startar.
Så fått radera och hasha om.
Hashfilen (HashIndex.xlm) har antagligen blivit förstor över 1.3gb delade ut lite mycket kanske.
Rensade lite share sen fungerade det bra igen.
Men har talat om det för utvecklarna.
Det har jag med upplevt. Det hände ldcpp kraschade en gång. Vad jag inte visste var att det forfarande körde (utan gui) och när jag startade en till dcpp så blev något väldigt fel. Fick även jag, hasha om.
Image

Använder Ubuntu Dapper.

User avatar
Biffy
Posts: 1970
Joined: 22 March 2004, 22:26
Location: /home

Post by Biffy » 13 July 2006, 21:29

Råkade just ut för en liten bug:

http://developer.berlios.de/bugs/?func= ... up_id=2230

Har en fil med ett "Ö" i, och den blir re-hashad varje gång jag startar dcpp. Det innebär 100% cpu usage under två minuter. :(
Image

Använder Ubuntu Dapper.

User avatar
mucha
Posts: 150
Joined: 5 October 2002, 11:58
Location: Östhammar

Post by mucha » 13 July 2006, 22:33

Biffy wrote:Råkade just ut för en liten bug:

http://developer.berlios.de/bugs/?func= ... up_id=2230

Har en fil med ett "Ö" i, och den blir re-hashad varje gång jag startar dcpp. Det innebär 100% cpu usage under två minuter. :(
Kör du nya cvsen? Det ska väl vara fixat på senare tid iaf
Image

User avatar
depeo
Posts: 1122
Joined: 20 October 2003, 19:46
Location: Västerås

Post by depeo » 13 July 2006, 23:01

byt alla Ö'n mot O'n, problemet löst. 8)

Post Reply