Tunnla VNC/X via SSH (Win - Linux)

Frågor kring allt som rör systemadministration.
Post Reply
User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Tunnla VNC/X via SSH (Win - Linux)

Post by Emil.s » 14 January 2006, 19:37

Jag, jag har ingen aning om hur man ska göra.

Jag kan koppla upp mig med Putty och det funkar bra.

Men var hittar jag en X server till Win, eller en VNC klient? Och hur tunnar jag det sen via SSH?

Förklara utförligt, har aldrig gjort något liknande förut :wink:
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 14 January 2006, 20:21

Med Cygwin kan du installera en xserver på win.

Med ssh så använs detta kommando för vnc.
ssh -L 5901:127.0.0.1:5900 user@server
Borde funka med putty med.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 14 January 2006, 20:48

Nille_kungen wrote:Med Cygwin kan du installera en xserver på win.

Med ssh så använs detta kommando för vnc.
ssh -L 5901:127.0.0.1:5900 user@server
Borde funka med putty med.
Ska kolla på Cygwin

Men det jag inte vet är hur man ska göra en "-L" i Putty.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

lefant
Posts: 382
Joined: 19 April 2005, 20:29

Post by lefant » 14 January 2006, 21:21

Emil.s wrote:Men det jag inte vet är hur man ska göra en "-L" i Putty.
Ett bra tag sedan jag använde windos, men jag har för mig
att det räcker med att trycka meta(flagga)+r för att komma
till kommando-promten.

Sedan antar jag att det bara är att skriva något i stil med
putty.exe flaggorochargument.

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 14 January 2006, 21:24


Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 14 January 2006, 22:18

Du får väl testa putty.exe -ssh -L 5901:127.0.0.1:5900 user@server
Då jag inte har windows så vet jag inte.

Annars kan du använda plink -L 5901:127.0.0.1:5900 user@server
Eller kollar du denna länk http://martybugs.net/smoothwall/puttyvnc.cgi[/url]
Sök på google annars. (och välj valfritt en av dom 3st första träffarna) :p
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 15 January 2006, 00:45

Så man kan köra putty i CMD? (windows command line).

Har inte testat. Men jag ska prova. Jag återkommer väl. :wink:
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 15 January 2006, 22:25

Jag testade precis. Det funkar bra med -L o.s.v.

Men var kan man få tag på en X server eller en VNC klient? Helst så liten som möjligt. Och GRATIS.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 15 January 2006, 22:48

Till vilket OS ?
VNC brukar väl vara gratis.
http://www.realvnc.com/cgi-bin/download.cgi är en av många sidor du kan tanka ifrån.
Vill du bara ha klient så välj viewer.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 15 January 2006, 23:16

Nille_kungen wrote:Till vilket OS ?
VNC brukar väl vara gratis.
http://www.realvnc.com/cgi-bin/download.cgi är en av många sidor du kan tanka ifrån.
Vill du bara ha klient så välj viewer.
Till windos. Men jag har hittat flera olika förut så...

Men jag ska testa imorrn. Borde väl inte bli några större problem. (hoppas jag :wink: )

Att tunnla X kanske blir segt med 0.5Mbit men men... Jag ska testa med Cygwin, men finns det någon "bra" x-server till Win?
Jag hittade någon förut. Men jag vet inte om den funkade så bra :s
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 15 January 2006, 23:22

TightVNC är GPL och finns till Microsoft Windows.

http://www.tightvnc.com/download.html

User avatar
Bar-Code
Posts: 838
Joined: 22 November 2002, 07:21

Post by Bar-Code » 16 January 2006, 07:29

Kör du VNC behöver du ingen X-server för Windows. TightVNC kräver inte mycket bandbredd, och du har många valmöjligheter för att begränsa bandbredden ytterligare, så testa på det. TightVNC klienten behöver dessutom inte installeras, så det enda du behöver om du är borta och vill komma åt din dator hemma är att tanka ner TightVNC klienten och starta den utan installation.

Det är smidigare än att installera en X-server tycker jag om man bara vill kunna komma åt sin hemdator.
There are 10 kinds of people; those who understand binary, and those who don't.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 16 January 2006, 08:42

Hm, Visst startar man Vnc Servern med "vncserver"? Blir så här i allafall:

MegaLeif ~ # vncserver
-bash: vncserver: command not found

Jag har installerat:

* net-misc/vnc
Latest version available: 4.0-r1
Latest version installed: 4.0-r1
Size of downloaded files: 45,770 kB
Homepage: http://www.realvnc.com/
Description: Remote desktop viewer display system
License: GPL-2

OCH:

* x11-misc/x11vnc
Latest version available: 0.7.1-r1
Latest version installed: 0.7.1-r1
Size of downloaded files: 615 kB
Homepage: http://www.karlrunge.com/x11vnc/
Description: A VNC server for real X displays
License: GPL-2


Jag har för mig att det funkade förut. Är det något som fattas, eller?...
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 16 January 2006, 10:17

x11-misc/x11vnc är den jag brukar använda.
Och den startar jag med t.ex
x11vnc -storepasswd tacknille ~/.vncpassword
jag har nu skapa en lösenords fil med lösen tacknille i filen ~/.vncpassword (du kan välja vilken fil du vill ha lösen i)
Nu är det dags att starta den.
x11vnc -rfbauth ~/.vncpassword
The more linux u go, The slacker u get

User avatar
Bar-Code
Posts: 838
Joined: 22 November 2002, 07:21

Post by Bar-Code » 16 January 2006, 10:38

Tunnlingen ihop med det här fungerar fint:

Code: Select all

x11vnc -display :0 -localhost -rfbauth ~/.vncpassword
Då kan man bara komma åt x11vnc från localhost, och eftersom du använder PuTTY för att tunnla trafiken till din VNC-host så fungerar det prima!
There are 10 kinds of people; those who understand binary, and those who don't.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 16 January 2006, 17:14

Bar-Code wrote:Tunnlingen ihop med det här fungerar fint:

Code: Select all

x11vnc -display :0 -localhost -rfbauth ~/.vncpassword
Då kan man bara komma åt x11vnc från localhost, och eftersom du använder PuTTY för att tunnla trafiken till din VNC-host så fungerar det prima!
Funkade att köra nu från datorn hemma. Men jag kunde inte starta den från SSH. Men det kanske inte går?

Jag testade med det här:

Code: Select all

MegaLeif ~ # vncviewer

VNC viewer for X version 4.0 - built Nov 21 2005 12:56:19
Copyright (C) 2002-2004 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.

Mon Jan 16 16:54:28 2006
 CConn:       connected to host 62.101.44.145 port 5900
 main:        End of stream
Ska det vara så, eller är det något som är fel? Det ska väl komma upp någon sorts "VNC fönster" eller? Det hände inget i allafall.


Men varför funkar det inte med "vncserver"? Det har ju funkat förut!?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Bar-Code
Posts: 838
Joined: 22 November 2002, 07:21

Post by Bar-Code » 17 January 2006, 06:31

Emil.s wrote:Funkade att köra nu från datorn hemma. Men jag kunde inte starta den från SSH. Men det kanske inte går?
Jo det går. Jag gör det varje dag.
There are 10 kinds of people; those who understand binary, and those who don't.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 17 January 2006, 08:49

Bar-Code wrote:
Emil.s wrote:Funkade att köra nu från datorn hemma. Men jag kunde inte starta den från SSH. Men det kanske inte går?
Jo det går. Jag gör det varje dag.
Nej. Jag har testat lite mer. Om man testar i Textläge, så klagar det på att det inte hittar någon X server.

Nu i KDE och X så startar det.

Ska ha servern igång och testa sen från nån dator med Windows.

Eftersom det står: "PORT=5900" så anntar jag att det blir så här:
"putty.exe -ssh -L 5900:ip-på-satorn-som-ska-styras:5900"

Sen då? ska jag skriva något i terminalen, eller öppna VNC klienten i Windows och skriva in IP:n hit bara eller?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Bar-Code
Posts: 838
Joined: 22 November 2002, 07:21

Post by Bar-Code » 17 January 2006, 09:01

Emil.s wrote:Nej. Jag har testat lite mer. Om man testar i Textläge, så klagar det på att det inte hittar någon X server.

Nu i KDE och X så startar det.
Meningen med en VNC-server är ju att du ska kunna ansluta remote till en X-server på en dator, och alltså krävs det att X körs. x11vnc använder som standard en redan befintlig X-server display (display 0) och startar inte upp någon egen X display. Du måste alltså köra X för att det ska vara någon mening med VNC.
Emil.s wrote:Eftersom det står: "PORT=5900" så anntar jag att det blir så här:
"putty.exe -ssh -L 5900:ip-på-satorn-som-ska-styras:5900"

Sen då? ska jag skriva något i terminalen, eller öppna VNC klienten i Windows och skriva in IP:n hit bara eller?
Tunneln du har skapat fungerar så här:
En permanent anslutning upprättas mellan klienten och servern, från port 5900 på klienten till port 5900 på servern.
All trafik som går från klienten till port 5900 på klienten (!) alltså från klienten till localhost, port 5900, kommer att skickas vidare ut genom tunneln och hamna på servern med destinationsport 5900.

Det du ska göra nu är alltså att starta en VNC-klient på klienten och ansluta till localhost port 5900. Då kommer trafiken automatiskt att gå genom tunneln och hamna på servern med destinationsport 5900, och om VNC-servern är igång där och lyssnar på localhost så kommer den att svara.
VNC-klienten kommer då att öppna ett fönster där du kan styra VNC-servern.

Hängde du med?
There are 10 kinds of people; those who understand binary, and those who don't.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 17 January 2006, 09:07

Bar-Code wrote:
Emil.s wrote:Nej. Jag har testat lite mer. Om man testar i Textläge, så klagar det på att det inte hittar någon X server.

Nu i KDE och X så startar det.
Meningen med en VNC-server är ju att du ska kunna ansluta remote till en X-server på en dator, och alltså krävs det att X körs. x11vnc använder som standard en redan befintlig X-server display (display 0) och startar inte upp någon egen X display. Du måste alltså köra X för att det ska vara någon mening med VNC.
Emil.s wrote:Eftersom det står: "PORT=5900" så anntar jag att det blir så här:
"putty.exe -ssh -L 5900:ip-på-satorn-som-ska-styras:5900"

Sen då? ska jag skriva något i terminalen, eller öppna VNC klienten i Windows och skriva in IP:n hit bara eller?
Tunneln du har skapat fungerar så här:
En permanent anslutning upprättas mellan klienten och servern, från port 5900 på klienten till port 5900 på servern.
All trafik som går från klienten till port 5900 på klienten (!) alltså från klienten till localhost, port 5900, kommer att skickas vidare ut genom tunneln och hamna på servern med destinationsport 5900.

Det du ska göra nu är alltså att starta en VNC-klient på klienten och ansluta till localhost port 5900. Då kommer trafiken automatiskt att gå genom tunneln och hamna på servern med destinationsport 5900, och om VNC-servern är igång där och lyssnar på localhost så kommer den att svara.
VNC-klienten kommer då att öppna ett fönster där du kan styra VNC-servern.

Hängde du med?
Nu är jag helt med :D

Hör väl av mig, om hur det funkar.

Men när jag försökte starta servern från SSH så var X i allafall igång i bakgrunden! Går det inte att komma förbi på något sätt?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Bar-Code
Posts: 838
Joined: 22 November 2002, 07:21

Post by Bar-Code » 17 January 2006, 10:03

Emil.s wrote:Men när jag försökte starta servern från SSH så var X i allafall igång i bakgrunden! Går det inte att komma förbi på något sätt?
Om X servern är igång så ska det fungera att köra x11vnc från en terminalanslutning över SSH. Jag gör så varje gång jag vill använda VNC hem till VNC-servern.

Posta gärna felmeddelandet så kan man kika på det :)
There are 10 kinds of people; those who understand binary, and those who don't.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 17 January 2006, 10:45

Nu är det så här:

Jag ansluter så här:

Code: Select all

C:\>"C:\Documents and Settings\User\Skrivbord\putty.exe" -L 5900:62.101.44.145:5900
Då öppnas "Putty". man ansluter som vanligt på port 22 men om man kikar i inställningarna så är 5900 tunnlad.
Det står så iallafall. Men går det att kolla på något sätt?

Jag har provat med både "Real-VNC" och "Tight-VNC".
Om jag ansluter till min ip hemma så får jag medelandet: Connection Failed i Real VNC. I Tight: Connection Failed

Till 127.0.0.0:
Tight: Failed to connect to server
Real: Connection Failed

x11vnc =

Code: Select all

MegaLeif ~ # x11vnc

Settings:
 display:    null
 authfile:   null
 subwin:     0x0
 -sid mode:  0
 flashcmap:  0
 force_idx:  0
 visual:     null
 overlay:    0
 ovl_cursor: 1
 scaling:    0 1.00000
 viewonly:   0
 shared:     0
 conn_once:  1
 timeout:    0
 inetd:      0
 connect:    null
 connectfile null
 vnc_conn:   1
 allow:      null
 input:      null
 passfile:   null
 accept:     null
 gone:       null
 users:      null
 using_shm:  1
 flipbytes:  0
 onetile:    0
 solid:      null
 blackout:   null
 xinerama:   0
 xrandr:     0
 xrandrmode: null
 padgeom:    null
 logfile:    null
 logappend:  0
 rc_file:    ""
 norc:       0
 bg:         0
 mod_tweak:  1
 isolevel3:  0
 xkb:        0
 skipkeys:   null
 addkeysyms: 0
 xkbcompat:  0
 clearmods:  0
 remap:      null
 norepeat:   1
 nofb:       0
 watchbell:  1
 watchsel:   1
 watchprim:  1
 cursor:     1
 multicurs:  0
 curs_mode:  null
 xfixes:     1
 alphacut:   240
 alphafrac:  0.33
 alpharemove:0
 alphablend: 1
 cursorshape:1
 cursorpos:  1
 xwarpptr:   0
 buttonmap:  null
 dragging:   1
 ptr_mode:   2
 inputskip:  10
 speeds:     null
 debug_ptr:  0
 debug_key:  0
 defer:      30
 waitms:     30
 take_naps:  1
 sb:         60
 sigpipe:    null
 threads:    0
 fs_frac:    0.75
 gaps_fill:  4
 grow_fill:  3
 tile_fuzz:  2
 snapfb:     0
 gui:        0
 gui_mode:   null
 noremote:   0
 safemode:   1
 deny_all:   0

17/01/2006 10:26:24 x11vnc version: 0.7.1 lastmod: 2005-02-23
17/01/2006 10:26:24
17/01/2006 10:26:24 *** XOpenDisplay failed. No -display or DISPLAY.
17/01/2006 10:26:24 *** Trying ":0" in 4 seconds.  Press Ctrl-C to abort.
17/01/2006 10:26:24 *** 1 2 3 4
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
17/01/2006 10:26:28
17/01/2006 10:26:28 XOpenDisplay failed (:0)
Vad är fel?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 17 January 2006, 12:16

17/01/2006 10:26:24 *** XOpenDisplay failed. No -display or DISPLAY.
17/01/2006 10:26:24 *** Trying ":0" in 4 seconds. Press Ctrl-C to abort.
17/01/2006 10:26:24 *** 1 2 3 4
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
17/01/2006 10:26:28
17/01/2006 10:26:28 XOpenDisplay failed (:0)
Jag tror bara att du inte lagt till eller använder fel display i kommandot.

Du kan avän göra detta för att lägga till en MIT-MAGIC-COOKIE. (men tror inte det ska behövas, då det är för att få köra ny display)

Code: Select all

xauth
xauth> list
Borde visa typ detta.
0.0.0.0:0 MIT-MAGIC-COOKIE-1 68d682a4f137b4f4679248eybc36a7c5
xeroc/unix:0 MIT-MAGIC-COOKIE-1 68d682a4f137b4f4679248eybc36a7c5

Detta betyder att vi bara får använda display 0
Vi kan lägga till display 1 också

xauth> add :1.0 MIT-MAGIC-COOKIE-1 68d682a4f137b4f4679248eybc36a7c5
xauth> exit
The more linux u go, The slacker u get

User avatar
Bar-Code
Posts: 838
Joined: 22 November 2002, 07:21

Post by Bar-Code » 17 January 2006, 12:26

Den här kommandoraden använder jag:

Code: Select all

x11vnc -display :0 -localhost -nopw -scale 0.8
Använd lösenord för en säkrare inloggning. Skippa alltså helst -nopw.
Argumentet -display :0 tvingar x11vnc att använda X serverns display 0.
There are 10 kinds of people; those who understand binary, and those who don't.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 17 January 2006, 14:29

Funkar inte med det heller. "-scale 0.8". Vad står det för?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 17 January 2006, 14:42

Om du läser README filen som följer med x11vnc så finner du alla svar.
I den står hur du tunnlar mm.
Den förklarar även det felmedelandet du fick innan.
Så läs den först sedan om du får problem så fråga igen.
The more linux u go, The slacker u get

User avatar
Bar-Code
Posts: 838
Joined: 22 November 2002, 07:21

Post by Bar-Code » 17 January 2006, 14:43

Emil.s wrote:Funkar inte med det heller. "-scale 0.8". Vad står det för?
man x11vnc

Code: Select all

 -scale fraction

              Scale  the  framebuffer  by factor fraction.  Values less than 1
              shrink the fb, larger ones expand it.  Note: image  may  not  be
              sharp  and response may be slower.  If fraction contains a deci-
              mal point "." it is taken as a floating point  number,  alterna-
              tively  the  notation  "m/n"  may  be  used  to denote fractions
              exactly, e.g. -scale 2/3

              Scaling Options: can be added after fraction via ":", to  supply
              multiple  ":"  options  use  commas.   If you just want a quick,
              rough scaling without blending, append ":nb" to  fraction  (e.g.
              -scale  1/3:nb).   No  blending  is the default for 8bpp indexed
              color, to force blending for this case use ":fb".

              To disable -scrollcopyrect and -wirecopyrect  under  -scale  use
              ":nocr".   If  you  need  to to enable them use ":cr" or specify
              them explicitly  on  the  command  line.   If  a  slow  link  is
              detected, ":nocr" may be applied automatically.  Default: :cr

              More  esoteric  options:  for  compatibility with vncviewers the
              scaled width is adjusted to be a multiple of 4: to disable  this
              use  ":n4".  ":in" use interpolation scheme even when shrinking,
              ":pad" pad scaled width and height to be  multiples  of  scaling
              denominator (e.g. 3 for 2/3).
There are 10 kinds of people; those who understand binary, and those who don't.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 17 January 2006, 22:37

Åhh, Jag sitter och läser i Man pages nu. Men jag tror hag kom på en egen lösning.

Men. Vart ska man egentligen ansluta? Om man är vid klienten, är det till "localhost" då? alltså till localhost på klienten.

För jag skrev ju "127.0.0.0" ahhh! Det ska ju vara en 1:a på slutet :oops:

Kanske funkar då?

Jag har läst i manualen. Fattar inte så mycket. Men jag ska göra ett nytt försök imorrn
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 17 January 2006, 22:41

Du behöver inte läsa manualen, jag skrev README till x11vnc.
I den finns det bra förklaring samt exempel på hur du ansluter.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 6 February 2006, 13:44

Nille_kungen wrote:Du behöver inte läsa manualen, jag skrev README till x11vnc.
I den finns det bra förklaring samt exempel på hur du ansluter.
Hittar ingen "Readme". men däremot en beskrivning på deras hemsida:

Code: Select all

Tunnelling x11vnc via ssh:
The above example had no security or privacy at all. When logging into remote machines (certainly when going over the internet) it is best to use ssh, or use a VPN. For x11vnc one can tunnel the VNC protocol through the encrypted ssh channel. It would look something like this: 

  sitting-here> ssh -L 5900:localhost:5900 far-away.east 'x11vnc -localhost -display :0'

(you will likely have to provide passwords/passphrases for the ssh login) and then in another terminal window on sitting-here run the command: 
  sitting-here> vncviewer -encodings "copyrect tight zrle hextile" localhost:0

Note: The -encodings option is very important: vncviewer will default to "raw" encoding if it thinks the connection is to the local machine, and so vncviewer gets tricked this way by the ssh redirection. "raw" encoding will be extremely slow over a networked link, so you need to force the issue with -encodings "copyrect tight ...". 

Note that "x11vnc -localhost ..." limits incoming vncviewer connections to only those from the same machine. This is very natural for ssh tunnelling (the redirection appears to come from the same machine). Use of a VNC password is also strongly recommended. 

Some VNC viewers will do the ssh tunnelling for you automatically, the TightVNC vncviewer does this when the "-via far-away.east" option is supplied to it (this requires x11vnc to be already running on far-away.east or having it started by inetd(1)). See the 3rd script example below for more info. 

If the machine you SSH into is not the same machine with the X display you wish to view (e.g. your company provides incoming SSH access to a gateway machine), then you need to change the above to, e.g.: "-L 5900:otherhost:5900". Once logged in, you'll need to do a second login (ssh, rsh, etc.) to the workstation machine 'otherhost' and then start up x11vnc on it (if it isn't already running). For an automatic way to use a gateway and have all the network traffic encrypted (including inside the firewall) see chaining ssh's below 
Tunnlingen ser jag inga problem med. Men x11vnc vill ju inte äns starta från ssh! :evil:

Jag kunde utan problem starta det hemma, i KDE i och sen ansluta till det lokalt. Men nu från skolan blir det så här:

Code: Select all

emil@MegaLeif ~ $ x11vnc -display :0 -localhost

Settings:
 display:    :0
 authfile:   null
 subwin:     0x0
 -sid mode:  0
 flashcmap:  0
 force_idx:  0
 visual:     null
 overlay:    0
 ovl_cursor: 1
 scaling:    0 1.00000
 viewonly:   0
 shared:     0
 conn_once:  1
 timeout:    0
 inetd:      0
 connect:    null
 connectfile null
 vnc_conn:   1
 allow:      127.0.0.1
 input:      null
 passfile:   null
 accept:     null
 gone:       null
 users:      null
 using_shm:  1
 flipbytes:  0
 onetile:    0
 solid:      null
 blackout:   null
 xinerama:   0
 xrandr:     0
 xrandrmode: null
 padgeom:    null
 logfile:    null
 logappend:  0
 rc_file:    ""
 norc:       0
 bg:         0
 mod_tweak:  1
 isolevel3:  0
 xkb:        0
 skipkeys:   null
 addkeysyms: 0
 xkbcompat:  0
 clearmods:  0
 remap:      null
 norepeat:   1
 nofb:       0
 watchbell:  1
 watchsel:   1
 watchprim:  1
 cursor:     1
 multicurs:  0
 curs_mode:  null
 xfixes:     1
 alphacut:   240
 alphafrac:  0.33
 alpharemove:0
 alphablend: 1
 cursorshape:1
 cursorpos:  1
 xwarpptr:   0
 buttonmap:  null
 dragging:   1
 ptr_mode:   2
 inputskip:  10
 speeds:     null
 debug_ptr:  0
 debug_key:  0
 defer:      30
 waitms:     30
 take_naps:  1
 sb:         60
 sigpipe:    null
 threads:    0
 fs_frac:    0.75
 gaps_fill:  4
 grow_fill:  3
 tile_fuzz:  2
 snapfb:     0
 gui:        0
 gui_mode:   null
 noremote:   0
 safemode:   0
 deny_all:   0

06/02/2006 12:39:06 x11vnc version: 0.7.1 lastmod: 2005-02-23
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

06/02/2006 12:39:06 XOpenDisplay failed (:0)
Det är precis samma rad som jag använde hemma!!!

Men det står ju:

Code: Select all

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

06/02/2006 12:39:06 XOpenDisplay failed (:0)
Kan det ha något med det här att göra?:
http://bbs.linux.se/viewtopic.php?t=29753

Jag ska kolla på ditt svar Nille när jag kommer hem.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 8 February 2006, 11:50

Jag startade x11vnc när jag åkte till skolan. Och precis nyss anslöt jag. Och det funkade!

Men jag kan fortfarande inte starta servern från ssh. Eller inte från Textterminalen heller. Fast X är igång.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 8 February 2006, 16:55

JaJaJa!!! Det funkar! Jag vet inte vad jag gjort. Men nu funkar det. mysko det här.
Men äntligen. Nu ska jag bara få igång tunnlingen, nu körde jga utan. Men det borde ju inte vara några problem.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 8 February 2006, 22:38

Nu tror jag att jag kommit på en lösning. Men måste vara inloggad i X. Om man bara har inloggnings skärmen igång så funkar det inte.
Kanske borde tänkt på det tidigare :oops:

Men det blir ju krångligare för mig. Jag brukar ju bara starta datorn på "knappen" och sen åka till skolan.
iof inte så mycket mer att göra, men går det att logga in i KDE eller Fluxbox från ssh och sen starta x11vnc?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 8 February 2006, 22:44

Annars kan du använda vncserver. Då skapas en ny X-server och som man automatiskt loggas in i, istället för att använda den befintliga som i x11vnc.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 8 February 2006, 22:53

mikma wrote:Annars kan du använda vncserver. Då skapas en ny X-server och som man automatiskt loggas in i, istället för att använda den befintliga som i x11vnc.

Code: Select all

emil@MegaLeif ~ $ vncserver
bash: vncserver: command not found
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 9 February 2006, 01:43

Ja det går att starta xservern via ssh och sedan logga in med x11vnc.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 9 February 2006, 13:55

Ja, just ja. Det går ju i allafall att stara en till X display med "startx -- :1 vt8" om man bara ska använda den med SSH/x11vnc.

Men om jag skriver "startx" så startas X med KDE. Förmodligen för att det står:
XSESSION="kde-3.5"
i min rc.conf

OM jag skulle ta bort det därifrån vet jag inte vad som händer. men går det att lägga till någon parameter till "startx" som gör att det startar i Fluxbox?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 9 February 2006, 15:38

Detta fungerar för mej och öppna fluxbox.
xinit /etc/X11/xinit/xinitrc.fluxbox -- :1
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 9 February 2006, 17:17

Code: Select all

emil@MegaLeif ~ $ xinit /etc/X11/xinit/xinitrc.fluxbox -- :1

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/MegaLeif:1
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.14.1 i686 [ELF]
Current Operating System: Linux MegaLeif 2.6.15-gentoo-r1 #5 SMP PREEMPT Fri Jan 27 07:20:52 CET 2006 i686
Build Date: 14 January 2006
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Feb  9 16:14:44 2006
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 8
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Cannot open "/var/tmp/server-1.xkm" to write keyboard description
>                   Exiting
(EE) Couldn't load XKB keymap, falling back to pre-XKB keymap
Could not init font path element /usr/X11R6/lib/X11/fonts/local/, removing from list!
xinit:  No such file or directory (errno 2):  no program named "/etc/X11/xinit/xinitrc.fluxbox" in PATH

Specify a program on the command line or make sure that /usr/bin
is in your path.


waiting for X server to shut down

Code: Select all

emil@MegaLeif ~ $ fluxbox -display :1
Error: Couldn't connect to XServer
Går det att starta en X server utan att någon fönsterhanterare körs igång?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Sourcer
Posts: 1183
Joined: 15 October 2005, 21:37

Post by Sourcer » 9 February 2006, 17:24

X :wink:

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 9 February 2006, 18:07

Sourcer wrote:X :wink:
ahha, 8)

Men det funkar inte så bra.

Code: Select all

X :1 vt8
Men det fryser precis som här:
http://bbs.linux.se/viewtopic.php?t=29753

Jag ser skärmen, och kan röra på musen. Men jag kan inte byta tillbaka.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Post Reply