Probem vid uppstart

Frågor kring allt som rör systemadministration.
Post Reply
warzo
Posts: 52
Joined: 9 April 2003, 13:07

Probem vid uppstart

Post by warzo » 5 October 2010, 00:13

När jag startar upp datorn ger den ett felmeddelande, efter att man valt från grub vilken kernel/kernel parametrar man vill boota med, ett felmeddelande:

hda: no response (status = 0xff, resetting drive)

Det tar ca 30 sekunder, och sedan tar det åter igen ca 30 sekunder innan det kommer för hdb, hdc och hdd. OS är installerat på en SCSI hårdskiva som då är /dev/sda. Vad jag inte förstår är varför den försöker få kontakt ens till någon av hd(x). Jag har inte något i fstab som hänvisar till dem, och inte har jag haft fast någon hd(x) under installation.

klein
Posts: 4886
Joined: 1 April 2002, 02:00
Location: 43,41,41N, 7,15,47Ö

Re: Probem vid uppstart

Post by klein » 5 October 2010, 09:43

Heter i alla devicer SDx numer? HDx är väl borta?

warzo
Posts: 52
Joined: 9 April 2003, 13:07

Re: Probem vid uppstart

Post by warzo » 5 October 2010, 12:50

Nope, mina ide enheters betekning är hdX, och övriga (usb, scsi, sata osv) sdX

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Re: Probem vid uppstart

Post by fagerjan » 5 October 2010, 20:40

I grub betecknas alla typer av hårddiskar med hdN, där N är en siffra från 0 uppåt. Grubs beteckning skiljer sig från beteckningen i linux. I linux betecknas PATA-enheter hdX och SATA och SCSI sdX. USB emulerar SCSI. Tror inte att diskar som inte är IDE stöds överhuvudtaget då de redan var omodärna 1991 då Linus skapade linux.

Har du kontrollerat SCSI-kontrollerns BIOS-inställningar? Är disken korrekt jumprad, så att inte uppstarten är fördröjd?
Fagerjan

warzo
Posts: 52
Joined: 9 April 2003, 13:07

Re: Probem vid uppstart

Post by warzo » 6 October 2010, 11:01

Nej, jag har inte tänkt på att det skulle vara något i SCSI biosen, men jag skall ta och kolla upp om där kan finnas något.

Fader_Berg
Posts: 180
Joined: 2 September 2009, 09:31

Re: Probem vid uppstart

Post by Fader_Berg » 8 October 2010, 15:31

Undvik gamla ATA och kör nya PATA istället.

warzo
Posts: 52
Joined: 9 April 2003, 13:07

Re: Probem vid uppstart

Post by warzo » 13 October 2010, 10:02

Vid närmare eftertanke så kunde ju problemet inte vara i scsi-biosen, iom att det är i samband med laddningen av kernel som den blir och vänta på respons av /dev/hda -> /dev/hdd. Jag har aldrig tidigare varit med om att någon dator behöver få kontakt till hårdskivor som inte är fastkopplade eller ens har varit fastkopplade.

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Re: Probem vid uppstart

Post by fagerjan » 13 October 2010, 22:14

Har du modulen för SCSI-kontrollern i initrd.img?
Fagerjan

warzo
Posts: 52
Joined: 9 April 2003, 13:07

Re: Probem vid uppstart

Post by warzo » 14 October 2010, 09:38

Uuh, de vet jag inte. Alltså den bootar efter att den konstaterat att det inte finns något bakom /dev/hda->/dev/hdd.
Men vad är det jag skall kolla och hur?

Post Reply