Installera Gimpshop

Här diskuterar vi GIMP, OpenOffice, Emacs, VI och andra applikationer som finns under Linux / UNIX.
Post Reply
bowll
Posts: 59
Joined: 2 July 2006, 17:39

Installera Gimpshop

Post by bowll » 7 March 2007, 21:05

tankade en .tar.bz2 fil o packade upp den..

när jag sedan 'cd:ar' mig in i mappen i en terminal o ska köra './configure'
får jag ett error mot slutet:

Code: Select all

checking for GLIB - version >= 2.4.5... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.
någon so mvet vad det kan vara

tack på förhand
/b.


EDIT: kör xubuntu
newbie på allt :)

User avatar
mog
Posts: 1578
Joined: 2 April 2002, 02:00
Location: gbg
Contact:

Post by mog » 8 March 2007, 01:55

:idea: Du kanske inte har glib med version 2.4.5 eller högre installerat på din burk?

bowll
Posts: 59
Joined: 2 July 2006, 17:39

Post by bowll » 8 March 2007, 02:14

mog wrote::idea: Du kanske inte har glib med version 2.4.5 eller högre installerat på din burk?
hur tar jag reda på de?
och hur uppdaterar jag?

sökte paket men den hitta inget :S
newbie på allt :)

User avatar
mog
Posts: 1578
Joined: 2 April 2002, 02:00
Location: gbg
Contact:

Post by mog » 8 March 2007, 02:24

Ubuntu har väl nåt paketsystem du kan använda?
typ "apt-get -search glib" eller nåt likn..

Någon annan som sysslar med med Ubuntu kan nog klargöra hur det ligger till annars.

User avatar
drbrno
Posts: 2834
Joined: 6 October 2002, 05:01
Location: Lund
Contact:

Post by drbrno » 8 March 2007, 06:15

Det är väl libglib2.0-dev du ska ha.

bowll
Posts: 59
Joined: 2 July 2006, 17:39

Post by bowll » 9 March 2007, 20:38

drbrno wrote:Det är väl libglib2.0-dev du ska ha.
ja det var rätt. tack

stötte på ett nytt problem
installerade just GTK+ 2.10.9 och nu får jag detta error i GIMPSHOP installationen:

Code: Select all

checking for GTK+ - version >= 2.4.4... 
*** 'pkg-config --modversion gtk+-2.0' returned 2.10.9, but GTK+ (2.10.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.

EDIT: jag hade alltså inte GTK+ innan jag installerade det.
newbie på allt :)

User avatar
drbrno
Posts: 2834
Joined: 6 October 2002, 05:01
Location: Lund
Contact:

Post by drbrno » 10 March 2007, 08:59

Enligt meddelandet hade du en version av Gtk när du installerade. Hur installerade du och varför? Om det var för att kompilera Gtk-program (troligt) så är det bara libgtk2.0-dev du ska ha.

bowll
Posts: 59
Joined: 2 July 2006, 17:39

Post by bowll » 10 March 2007, 23:17

drbrno wrote:Enligt meddelandet hade du en version av Gtk när du installerade. Hur installerade du och varför? Om det var för att kompilera Gtk-program (troligt) så är det bara libgtk2.0-dev du ska ha.
jag installerade via source, och varför? fick ett felmeddelande av './configure' i gimpshop att jag behövde GTK+.
alltså att jag inte hade någon installation av GTK+ innan. sen installerade jag det o fick de där :-?
newbie på allt :)

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 10 March 2007, 23:27

GTK+ är widget toolkit:et som används av Gnome, och även xubuntu.
Eftersom du installerat GTK+ även från källkod så har du två uppsättningar av GTK+ biblioteken både i /usr/lib och /usr/local/lib. Installera libgtk2.0-dev istället.

bowll
Posts: 59
Joined: 2 July 2006, 17:39

Post by bowll » 10 March 2007, 23:53

mikma wrote:GTK+ är widget toolkit:et som används av Gnome, och även xubuntu.
Eftersom du installerat GTK+ även från källkod så har du två uppsättningar av GTK+ biblioteken både i /usr/lib och /usr/local/lib. Installera libgtk2.0-dev istället.
hm libgtk2.0-dev är installerat. och funkade tydligen inte med det innan isf.
är ju GTK+ jag ska ha inte GTK
men jag gjorde en 'make uninstall' på suorcen jag hade så nu funkade det :)
newbie på allt :)

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 11 March 2007, 00:00

Man kan bara ha bokstäver, siffror och bindestreck i namn på deb-paket, därför finns det inget "+"

I beskrivningen står däremot det fullständiga namnet:
Description: Development files for the GTK+ library

bowll
Posts: 59
Joined: 2 July 2006, 17:39

Post by bowll » 11 March 2007, 00:02

mikma wrote:Man kan bara ha bokstäver, siffror och bindestreck i namn på deb-paket, därför finns det inget "+"

I beskrivningen står däremot det fullständiga namnet:
Description: Development files for the GTK+ library
okej.. där ser man :) fel av mig!
konstigt då att jag fick fel när de var installerat.. men det är löst nu iaf!

EDIT:
jag får verkligen inte igång gimpshop..

Code: Select all

checking for GIMP-PRINT - version >= 4.2.0... no
*** The gimpprint-config script installed by GIMP-PRINT could not be found
*** If GIMP-PRINT was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GIMPPRINT_CONFIG environment variable to the
*** full path to gimpprint-config.
configure: error:
*** Check for libgimpprint failed. You can download it from
*** http://gimp-print.sourceforge.net/ or you can build without it by passing
*** --disable-print to configure (but you won't be able to print then).
har installerat paketet 'gimp-print' med apt-get..
så vad kan felet vara?
har kollat länken o hittat en source men får inte igång den via sourcen :(
newbie på allt :)

User avatar
drbrno
Posts: 2834
Joined: 6 October 2002, 05:01
Location: Lund
Contact:

Post by drbrno » 11 March 2007, 10:12

Som sagt (eller antytt), det är dev-paket du behöver för att kompilera program.

Nu verkar det dock vara lite krångligt med just gimp-print. Det har nyligen bytt namn till gutenprint, så det kan bli svårt att få in libgimpprint-dev. (Det finns inte längre?) Kanske, kanske funkar det med libgutenprint-dev.

bowll
Posts: 59
Joined: 2 July 2006, 17:39

Post by bowll » 12 March 2007, 22:55

drbrno wrote:Som sagt (eller antytt), det är dev-paket du behöver för att kompilera program.

Nu verkar det dock vara lite krångligt med just gimp-print. Det har nyligen bytt namn till gutenprint, så det kan bli svårt att få in libgimpprint-dev. (Det finns inte längre?) Kanske, kanske funkar det med libgutenprint-dev.
libgutenprint-dev fungerade det inte med.. :cry:
newbie på allt :)

Post Reply