MythTV Kompilerings error

Här diskuterar vi GIMP, OpenOffice, Emacs, VI och andra applikationer som finns under Linux / UNIX.
Post Reply
hedin
Posts: 26
Joined: 12 February 2007, 20:12

MythTV Kompilerings error

Post by hedin » 17 December 2007, 23:29

Hej.

Försöker bygga MythTV men får ett felmedelande ld: cannot find -lqt-mt

Har slackware 12 och qt-3.3.8-i486-4 installerat
/usr/lib/qt/lib# ls
libdesignercore.a , libqt-mt.la , libqui.so
libdesignercore.prl , libqt-mt.prl , libqui.so.1
libeditor.a , libqt-mt.so , libqui.so.1.0
libeditor.prl , libqt-mt.so.3 , libqui.so.1.0.0
libqassistantclient.a , libqt-mt.so.3.3 , pkgconfig
libqassistantclient.prl , libqt-mt.so.3.3.8
libqt-mt , libqui.prl

Googlat o fick fram något om att lägga till en länk /usr/lib/qt/lib/
ln -s libqt-mt.so.3.3.8 libqt-mt

Men funka inte någon som har något förslag vad det är?

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 18 December 2007, 22:26

Filen/länken som saknas är libqt-mt.so

hedin
Posts: 26
Joined: 12 February 2007, 20:12

Post by hedin » 19 December 2007, 10:58

Den finns redan som länk, libqt-mt.so -> libqt-mt.so.3.3.8.

Är qt beroende av några andra paket? Har en minimal installation.

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 19 December 2007, 19:36

I Debian kräver libqt3-mt-dev: libxext-dev (>= 4.3.0.dfsg.1-4), libxrandr-dev (>= 4.3.0.dfsg.1-4), libsm-dev (>= 4.3.0.dfsg.1-4), libxmu-dev (>= 4.3.0.dfsg.1-4), libice-dev (>= 4.3.0.dfsg.1-4), libx11-dev (>= 4.3.0.dfsg.1-4), libxt-dev (>= 4.3.0.dfsg.1-4), libxrender-dev, libxcursor-dev, libxinerama-dev, libxi-dev, zlib1g-dev, libjpeg62-dev, libmng-dev (>= 1.0.3), libpng12-dev | libpng12-0-dev, libfontconfig1-dev, libfreetype6-dev, libxft-dev, libaudio-dev, libcupsys2-dev, libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev, libc6-dev, libqt3-mt (= 3:3.3.7-9), libqt3-headers (= 3:3.3.7-9), qt3-dev-tools (= 3:3.3.7-9)

Post Reply