Användarnamn och grupp news

Här diskuterar vi GIMP, OpenOffice, Emacs, VI och andra applikationer som finns under Linux / UNIX.
Post Reply
andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Användarnamn och grupp news

Post by andersson » 22 January 2008, 11:14

På en maskin med Ubuntu 7.10 försöker jag skapa en ny användare och ny grupp som skall heta news.
Får upp meddelande om att det användarnamnet finns redan!
Varför och hur åtgärdar jag detta?
Namnet news kommer inte upp i användarinställningar!

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 22 January 2008, 14:10

Det finns en standardgrupp news. Du ser den med: cat /etc/group
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 22 January 2008, 18:20

OK!

Hör gör jag för att få katalogen news och alla filerna att ägas av news och tillhöra grupp news?

Fick detta felmeddelande:

Jan 22 19:32:19 ubuntu inndstart: must be run by user news (9), not 0

Hur ändrar jag filen inndstart?

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 22 January 2008, 22:04

Gå i en terminal tlill news förädrakatalog. Kör kommandot:

Code: Select all

sudo chown news:news news
Vad vill du ändra i filen inndstart? Rättigheterna ändra med chmod.
1 = körrättighet
2 = skrivrättighet
4 = läsrättighet
Första siffran är summan av ägarens rättigheter.
Andra siffran är summan av gruppens rättigheter.
Tredje siffran är summan av övrigas rättigheter.
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 22 January 2008, 22:21

Vi tar detta från början!
1. Jag är nybörjare på Linux.
2. Jag kör en newsserver just2write2.myftp.org på en windowsmaskin.
3. Har nyligen installerat Ubuntu 7.10 på en separat maskin.
4. Vill ha en newsserver på denna med programmet INN2.
5. Detta är ett mycket komplext program och kanske "omöjligt"
att konfigurera för en nybörjare på Linux!

Nu kommer frågan: hur kollar jag att programmet har startat upp?
Nästa fråga, får detta felmeddelande:
Jan 22 21:30:51 ubuntu inndstart: must be run by user news (9), not 0.
Hur gör jag för att bli user news?

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 23 January 2008, 15:50

Enligt manualsidan för inndstartkan programmet endast köras (av säkerhetsskäl) av användaren news eller en medlem i gruppen news. Så det borde fungera om du inkluderar diitt användarnamn i gruppen news.

Eller så byter du till news med:

Code: Select all

su news 
Du måste troligen först som root ändra lösenordet för news.
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 23 January 2008, 18:11

Tack får rådet!

Startar upp servern med:

Code: Select all

/etc/init.d/inn2 start
men är sedan osäker på om den är verkligen startad!

Code: Select all

telnet 192.xxx.x.xxx 119
ger detta meddelande:

telnet: Unable to connect to remote host: Connection refused]

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 23 January 2008, 21:45

Med ps -A ser du vilka processer som är igång. Meddelande du får tyder närmast på att brandväggen inte tillåter anslutning. Vad ger

Code: Select all

sudo iptables-save 
eller

Code: Select all

sudo iptables -L
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 23 January 2008, 22:24

den första koden gav:

# Generated by iptables-save v1.3.6 on Wed Jan 23 21:20:08 2008
*filter
:INPUT ACCEPT [101:8961]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [115:6912]
COMMIT
# Completed on Wed Jan 23 21:20:08 2008

den andra koden gav:

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Till saken hör att har jag igång DNews som också är en newsserver,
så kommer jag åt den via telnet. Bör ju inte vara brandväggen
då eller!?

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 24 January 2008, 16:08

Brandväggen är det inte då den är inställd att släppa igenom allt. Fanns inn2 med i det som ps -A gav?
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 24 January 2008, 16:17

Nej INN2 fanns inte med, men däremot:

3973 ? 00:00:00 innwatch

Kjell

från syslog:

Jan 24 16:10:01 ubuntu rnews: cant open_remote: Connection refused
Jan 24 16:10:23 ubuntu inndstart: must be run by user news (9), not 0
Jan 24 20:14:11 ubuntu inndstart: can't setgroups (is inndstart setuid root?): Operation not permitted
Jan 24 20:14:11 ubuntu inndstart: can't seteuid to 0: Operation not permitted

detta kan ju vara något!
Eftersom jag är novis hur gör jag?

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 24 January 2008, 22:17

Försök med att starta inndstart som användaren news. I Ubuntu blir du användare news med:

Code: Select all

sudo su news
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 24 January 2008, 22:36

det blev detta!!

kjell@ubuntu:/usr/lib/news/bin$ sudo su news inndstart start
inndstart: 1: Syntax error: "(" unexpected
kjell@ubuntu:/usr/lib/news/bin$

Körde detta
kjell@ubuntu:/etc/init.d$ sudo su news inn2 start
Starting news server:
Markören står och blinkar och förväntar sig något! Men vad?

Samtidigt finns detta i auth.log:

Jan 24 21:58:42 ubuntu sudo: kjell : TTY=pts/0 ; PWD=/etc/init.d ; USER=root ; COMMAND=/bin/su news inn2 start
Jan 24 21:58:42 ubuntu su[9268]: Successful su for news by root
Jan 24 21:58:42 ubuntu su[9268]: + pts/0 root:news
Jan 24 21:58:42 ubuntu su[9268]: pam_unix(su:session): session opened for user news by kjell(uid=0)


Sedan finns detta i log rc.news:

Lösenord:

Här står också markören och blinkar!
Har inget lösenord att fylla i![/code]

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 25 January 2008, 11:54

Starting and Stopping the System

INN is started via the shell script rc.news. This must be run as the
news user and not as root. To start INN on system boot, you therefore
want to put something like:

su - news -c /usr/local/news/bin/rc.news

in the system boot scripts. If innd is stopped or killed, you can
restart it by running rc.news by hand as the news user.

The rc.news script may also be used to shut down INN, with the "stop"
option:

su - news -c '/usr/local/news/bin/rc.news stop'

In the contrib directory of this source tree is a sample init script for
people using System V-style init.d directories.




Detta har jag skrivit i bootmisc.sh

su - news -c /usr/lib/news/bin/rc.news

När jag startar datorn kommer dessa felmeddelanden upp i log rc.news:
Starting innd.
inndstart: can't setgroups (is inndstart setuid root?): Operation not permitted
inndstart: can't seteuid to 0: Operation not permitted
Scheduled start of /usr/lib/news/bin/innwatch.

i log news.error kommer detta upp:
Jan 25 09:36:16 ubuntu inndstart: can't setgroups (is inndstart setuid root?): Operation not permitted
Jan 25 09:36:16 ubuntu inndstart: can't seteuid to 0: Operation not permitted

Har sedan kört:

Code: Select all

sudo chmod 7410 inndstart
efter rekommendationer härifrån:
http://www.eyrie.org/~eagle/software/in ... start.html

can't setgroups (is inndstart setuid root?): %s

(Warning) Dropping all supplemental groups except the news group failed for some reason, and the process group membership was left unchanged. This almost always indicates that inndstart isn't setuid root as it has to be to do what it does. Make sure that inndstart is setuid root, owned by group news, and mode 4710.

Efter detta får jag upp "endast" detta meddelande i log rc.news:
Starting innd.
eval: 1: /usr/lib/news/bin/inndstart: Permission denied
Scheduled start of /usr/lib/news/bin/innwatch.

Så läget är väl ungefär det samma!

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 25 January 2008, 18:56

andersson wrote:S

Har sedan kört:

Code: Select all

sudo chmod 7410 inndstart
efter rekommendationer härifrån:
http://www.eyrie.org/~eagle/software/in ... start.html
Skall vara:

Code: Select all

sudo chmod 4710 inndstart
Fagerjan

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 25 January 2008, 19:18

andersson wrote:det blev detta!!

kjell@ubuntu:/usr/lib/news/bin$ sudo su news inndstart start
inndstart: 1: Syntax error: "(" unexpected
kjell@ubuntu:/usr/lib/news/bin$

Körde detta
kjell@ubuntu:/etc/init.d$ sudo su news inn2 start
Starting news server:
Markören står och blinkar och förväntar sig något! Men vad?

Samtidigt finns detta i auth.log:

Jan 24 21:58:42 ubuntu sudo: kjell : TTY=pts/0 ; PWD=/etc/init.d ; USER=root ; COMMAND=/bin/su news inn2 start
Jan 24 21:58:42 ubuntu su[9268]: Successful su for news by root
Jan 24 21:58:42 ubuntu su[9268]: + pts/0 root:news
Jan 24 21:58:42 ubuntu su[9268]: pam_unix(su:session): session opened for user news by kjell(uid=0)


Sedan finns detta i log rc.news:

Lösenord:

Här står också markören och blinkar!
Har inget lösenord att fylla i![/code]
Du behöver inget lösenord för news om du gör dig till news med:

Code: Select all

sudo su  news

Det lösenord du skall fylla i är lösenordet för kjell.
När du sedan är news så kör du kommandot inndstart.
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 25 January 2008, 21:22

kjell@ubuntu:~$ cd /usr/lib/news/bin
kjell@ubuntu:/usr/lib/news/bin$ dir
actmerge expire innfeed nntpget send-ihave
actsync expireover innmail nntpsend sendinpaths
actsyncd expirerm innreport ovdb_init send-nntp
archive fastrm innstat ovdb_monitor send-uucp
auth filechan innupgrade ovdb_server send-uucp.pl
batcher filter innwatch ovdb_stat sendxbatches
buffchan getlist innxbatch overchan shlock
buildinnkeyring ginpaths2 innxmit perl-nocem showtoken
cnfsheadconf gpgverify mailpost pgpverify shrinkfile
cnfsstat grephistory makedbz procbatch signcontrol
control imapfeed makehistory prunehistory sm
controlbatch inews mod-active pullnews startinnfeed
controlchan inncheck news2mail rc.news tally.control
convdate innconfval news.daily rnews tdx-util
ctlinnd innd ninpaths rnews.libexec writelog
cvtbatch inndf nnrpd scanlogs
docheckgroups inndstart nnrpd-ssl scanspool
kjell@ubuntu:/usr/lib/news/bin$ sudo su news
$ inndstart
sh: inndstart: not found
$

kratz
Posts: 1121
Joined: 9 May 2005, 17:21
Location: ~/Högsby
Contact:

Post by kratz » 25 January 2008, 22:37

andersson wrote:kjell@ubuntu:~$ cd /usr/lib/news/bin
kjell@ubuntu:/usr/lib/news/bin$ dir
actmerge expire innfeed nntpget send-ihave
actsync expireover innmail nntpsend sendinpaths
actsyncd expirerm innreport ovdb_init send-nntp
archive fastrm innstat ovdb_monitor send-uucp
auth filechan innupgrade ovdb_server send-uucp.pl
batcher filter innwatch ovdb_stat sendxbatches
buffchan getlist innxbatch overchan shlock
buildinnkeyring ginpaths2 innxmit perl-nocem showtoken
cnfsheadconf gpgverify mailpost pgpverify shrinkfile
cnfsstat grephistory makedbz procbatch signcontrol
control imapfeed makehistory prunehistory sm
controlbatch inews mod-active pullnews startinnfeed
controlchan inncheck news2mail rc.news tally.control
convdate innconfval news.daily rnews tdx-util
ctlinnd innd ninpaths rnews.libexec writelog
cvtbatch inndf nnrpd scanlogs
docheckgroups inndstart nnrpd-ssl scanspool
kjell@ubuntu:/usr/lib/news/bin$ sudo su news
$ inndstart
sh: inndstart: not found
$
Varför använder du "dir"? "ls" är väl betydligt mycket bättre på alla sätt?
För att exekvera en fil måsste du visa var den finns. Du befinner dig i filens katalog vilket innebär att du måsste sätta "./" framför filen om den ska exekveras, dvs. "./inndstart" så startar filen om den är exekverbar.
Om den inte är det så kan du göra den exekverbar med "chmod +x inndstart", och du kan, om det är tex. ett sh-script, köra den med "sh inndstart" även om den inte är exekverbar.

Om du bara skriver tex inndstart i sh/bash så kommer sh/bash leta i katalogerna som är defenierade i variabeln $PATH efter en fil som heter inndstart. Om då inte /usr/lib/news/bin finns i $PATH så kommer den inte hitta filen.

Du verkar vara MSDOS-skadad;) Inget illa menat med det, men det märks att du antar att det ska fungera som i DOS.
Välkommen till http://archlinux.se !

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 26 January 2008, 15:44

Jag är nog dos-skadad! Svårt att börja tänka i lite andra banor.

Fortfarande gäller det väsentliga:

Code: Select all

kjell@ubuntu:~$ telnet localhost 119
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused
kjell@ubuntu:~$ 
Detta är det primära som jag måste lösa innan jag går vidare!
Startar jag upp DNews newsserver ser det genast bättre ut!

Code: Select all

kjell@ubuntu:~$ telnet localhost 119
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
200 just2write2.myftp.org DNEWS Version  5.7e1,, S0, posting OK 
Vad kan man göra vidare?

kratz
Posts: 1121
Joined: 9 May 2005, 17:21
Location: ~/Högsby
Contact:

Post by kratz » 26 January 2008, 16:27

Nu har jag inte läst igenom tråden, det är möjligt att detta redan tagits upp.
Hur ser din /etc/hosts.allow samt /etc/hosts.deny ut?
Välkommen till http://archlinux.se !

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 26 January 2008, 16:34

de ser ut att vara orörda:

# /etc/hosts.allow: list of hosts that are allowed to access the system.
# See the manual pages hosts_access(5) and hosts_options(5).
#
# Example: ALL: LOCAL @some_netgroup
# ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
# for further information.
#


# /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
# See the manual pages hosts_access(5) and hosts_options(5).
#
# Example: ALL: some.host.name, .some.domain
# ALL EXCEPT in.fingerd: other.host.name, .other.domain
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
# for further information.
#
# The PARANOID wildcard matches any host whose name does not match its
# address.

# You may wish to enable this to ensure any programs that don't
# validate looked up hostnames still leave understandable logs. In past
# versions of Debian this has been the default.
# ALL: PARANOID

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 26 January 2008, 21:21

Vad finns i /var/log/news? Du måste använda sudo för att få läsa loggen.
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 26 January 2008, 21:38

Skall göra en helt ny installation!
Skall installera Ubuntu 7.10
Efter installerar jag INN2
Enligt manual för installation , se nedan
Skall man innan detta se till att skapa en användare news som skall höra till gruppen news.
Det går för tusan inte att skapa en ny användare news eftersom den redan tillhör systemet! Skapa gruppen går men inte att få den att tillhöra användaren news.
Är detta samma system på alla linuxdistrubutioner?
Finns det ett sett att kringå detta?
Enligt manual:
Before beginning installation, you should make sure that there is a user on your system named news, and that this user's primary group is set to a group called news.
Alltså detta ovanstående går ej att göra enligt mitt sett att se.
Jag vill kunna starta datorn och logga in som news och då helt slippa alla dessa rättigheter. Böjar liksom få spader på detta!
Till saken hör att jag får alltid upp detta felmeddelande vid installation av INN2 :
"E:inn2:underprocess post-installation script gav felkod 1"

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 26 January 2008, 23:50

Code: Select all

kjell@ubuntu:~$ sudo su news
$ /etc/init.d/inn2 start
Starting news server: 
Den står och väntar på ett lösenord som jag inte har!

Samtidigt poppar detta upp i /var/log/news/rc.news
Lösenord:

Jag har inget lösenord för news eftersom news tillhör systemet.
Går detta på något vis att ändra på
Detta börjar bli knasigt!!!!

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 27 January 2008, 10:43

God morgon!?

Vid uppstart av dator kommer dessa felmeddelanden i /var/log/news:

Starting innd.
eval: 1: /usr/lib/news/bin/inndstart: Permission denied
Scheduled start of /usr/lib/news/bin/innwatch.

Vad göra åt permission dinied?

Code: Select all

kjell@ubuntu:/usr/lib/news/bin$ ls -l inndstart
-r-sr-x--- 1 root news 35220 2007-08-10 14:11 inndstart
kjell@ubuntu:/usr/lib/news/bin$
Enligt nedanstående är rättigheterna riktiga men där står annat som jag inte är riktigt klar över!

Thanks. It seems that the news account and the news group
is multiply defined (in /etc/passwd, /etc/group as well as in
NIS). Grrr..

Have a great Thanksgiving

> divya <divya@xxxxxxxxxx> writes:
>
>> OK,
>> I treid that too:
>
>> [root]$ ls -l /export/usr1/news/inn-2.4.1/bin/inndstart
>> -r-sr-x--- 1 root news 88497 Nov 24 12:19
>> /export/usr1/news/inn-2.4.1/bin/inndstart
>
>> Now it says:
>
>> /export/usr1/news/inn-2.4.1/bin/rc.news: line 1:
>> /export/usr1/news/inn-2.4.1/bin/inndstart: Permission denied
>
>> !!!
>
> That sounds like whatever user you're starting INN as isn't in the news
> group.

detta kommer upp i syslog:

Jan 27 10:30:45 ubuntu inndstart: must be run by user news (9), not 0
Jan 27 10:31:59 ubuntu innd: SERVER innd MUST be started with inndstart

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 27 January 2008, 16:50

Lösenord ändras med passwd. Som root kan du ändra en användares lösenord utan att känna till eventuellt gammalt lösenord.
Tag bort dubletterna med userdel resp. groupdel.
Användaren och gruppen news skall ha samma nummer. Numret syns i filerna /etc/passwd (användare) och /etc/group.

Läs programmens manualfiler, som visas med kommandot: man programnamn. Kommandot man man visar manualen för hur manualsidorna används.
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 28 January 2008, 14:51

vad får man ut av detta?

etc/group
news:x:9:kjell,root

/etc/passwd
news:x:9:65534:news,,,,:/var/spool/news:/bin/sh

grundproblemet är alltså nedanstående,
varför kan jag inte lista ut!
det är alltså så inn skall startas med rc.news.
Detta har jag i /etc/init.d/ bootmisc.sh

Code: Select all

su - news -c /usr/lib/news/bin/rc.news

Code: Select all

kjell@ubuntu:/usr/lib/news/bin$ sudo su news
$ ./rc.news
Starting innd.
eval: 1: /usr/lib/news/bin/inndstart: Permission denied
Scheduled start of /usr/lib/news/bin/innwatch.

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 28 January 2008, 16:17

Du har fel grupper för news i /etc/passwd. Du har 65534 istället för 9. Raden bör vara: news:x:9:9:news:/var/spool/news:/bin/sh
Kolla rättigheterna för /usr/lib/news och dess underkataloger. Bör vara 0755.
Fagerjan

andersson
Posts: 26
Joined: 8 January 2008, 16:26
Contact:

Post by andersson » 28 January 2008, 22:40

Du har lyckats med att göra min dag mycket lättare! Tack

Servern är igång!

Återstår kanske mycket ännu!

Eftersom jag har en server, just2write2.myftp.org gående vill jag inte
öppna till internet ännu med denna maskin.
Får hålla på med att testa den så gott det går,
innan jag försöker sätta den i drift.

Har inte ändrat rättigheterna för
/usr/lib/news och dess underkataloger ännu
vill vara helt säker när jag kommit så här långt!
Det gäller alltså alla filer också?

Mitt förslag:

Code: Select all

 chmod 0755 /usr/lib/news
För att gälla allt kan jag då skriva så här?

Code: Select all

chmod 0755 /usr/lib/news*

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 29 January 2008, 15:53

Du skall inte skriva chmod 0755 /usr/lib/news* utan chmod -R 0755 /usr/lib/news.
Ditt alternativ ändrar rättigheterna på alla filer vars namn börjar på news i katalogen /usr/lib.
Vad jag förstår vill du ändra på rättigheterna på alla filer i /usr/lib/news och dess inderkataloger. Det åstadkoms med parametern -R (eller --recursive).

Skönt att du fick igång servertn. :)
Fagerjan

Post Reply