Port vägrar fungera

Diskussion kring säkerhet och nätverk.
Post Reply
Flygisoft
Posts: 52
Joined: 22 December 2005, 15:16
Location: Örnsköldsvik, Sverige
Contact:

Port vägrar fungera

Post by Flygisoft » 15 April 2010, 21:28

Hej,
Jag sitter med Debian och ska köra en ident-server (oidentd) under port 113. Enligt min leverantör där server står så ska porten vara öppen i brandväggen, mina iptables är också helt rena och har inte installerat några övriga brandväggar.
Jag upptäckte även att UDP 113 fungerar dock inte TCP. Jag försökte även köra telnet från servern mot min egna dator på port 113 vilket slog ifrån direkt med "Connection refused" (jag kontrollerade från en annan dator att min port var öppen vilket den var).
Alltså verkar ju varken ingående eller utgående anslutningar fungera under port TCP 113.

Serverprogram i övrigt på servern är apache2, mysql, postfix och zarafa.

Vad är det för mysko fel? :(

miixter
Posts: 924
Joined: 29 July 2003, 21:37

Re: Port vägrar fungera

Post by miixter » 16 April 2010, 01:20

Står det något i loggar under '/var/log' som skulle kunna vara intressant..?

Hur ser /etc/hosts, /etc/hosts.allow, /etc/hosts.deny ut, kan det vara så att ident är denied i tcpwrappern?

/miixter
Key power of Linux - freedom to choose.

Flygisoft
Posts: 52
Joined: 22 December 2005, 15:16
Location: Örnsköldsvik, Sverige
Contact:

Re: Port vägrar fungera

Post by Flygisoft » 16 April 2010, 12:56

Jag har kollat filerna du nämnde, det vara bara /etc/hosts som inte hade bara kommenterad text.

Code: Select all

127.0.0.1       localhost
127.0.1.1       flygisoft

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Jag har även kollat runt i loggarna tidigare och har inte hittat något intressant.
Jag kan dock köra telnet mot porten lokalt via extern IP och localhost, dock så lämnar väl troligen aldrig anslutningen datorn.

Post Reply