Starta en till X display

Är Ni nybörjare i UNIX/Linux? Detta forum avhandla allmäna UNIX frågor.
Post Reply
User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Starta en till X display

Post by Emil.s » 3 February 2006, 17:59

på Kmenyn så kan man göra så här:

Byt användare - Ny session

Då staras en ny "display". Alltså kan man byta med "Ctrl + Alt F7/F8"

Hur gör man för att starta en ny display från terminalen?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 3 February 2006, 18:52

Prova "startx -- :1"

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 3 February 2006, 23:16

Code: Select all

startx -- :1 vt8
vt8 anger att X startas på virtual terminal 8 (ALT+CTRL+F8 ).
Nästa startx -- :2 vt9 o.s.v.
Fagerjan

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 3 February 2006, 23:33

Code: Select all

startx -- :2 vt8
Det funkar... Men jag kan inte byta tillbaka sen. Då måste jag logga ut. Och då stängs displayen ner.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

OErjan
Posts: 1834
Joined: 21 April 2003, 06:43
Location: 64*N 21*E

Post by OErjan » 4 February 2006, 14:15

va?? ctrl+alt+F7 borde funka prima, jag gör ju så till och från juh
kanske jag är en av de sista människor som ser din gamla: bil, dator, gräsklippare...
efter mig är de så många kilo konfetti.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 4 February 2006, 19:27

OErjan wrote:va?? ctrl+alt+F7 borde funka prima, jag gör ju så till och från juh
Tycker jag med. Men inget går. Inte + F1 heller.

Och när man trycker på "Avsluta session" så kraschar X. Det blir massa konstiga färger och linjer över hela skärman. Olika varje gång.
Så har det blivit ibland förut också. T.ex när man ska logga ut sig.

Då kan man trycka CTRL + ALT + F1. Då blir det ett annat mönster på skärman och andra färger. Men det går inte att göra någon ting. Bara att dra ur sladden.

Någon som vet något om detta?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 4 February 2006, 20:05

Fungerar det att stänga X med CTRL+ALT+BSPC? Då skall du komma tillbaka till terminalprompten. Du kör väl inte startx-kommandot från en konsol i KDE?
Fagerjan

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 4 February 2006, 20:30

fagerjan wrote:Fungerar det att stänga X med CTRL+ALT+BSPC? Då skall du komma tillbaka till terminalprompten. Du kör väl inte startx-kommandot från en konsol i KDE?
1. Nej. Men det blir att annat mönster igen.
2. Spelar ingen roll om jag startar det från KDE eller Textläge.
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 4 February 2006, 23:17

Startar du flera X från samma terminal eller från olika terminaler?
Fagerjan

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 4 February 2006, 23:55

fagerjan wrote:Startar du flera X från samma terminal eller från olika terminaler?
när jag startar datorn startas X med /etc/init.d/xdm start
alltså

Code: Select all

rc-update add xdm default
Sen så vet du hur det blir
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 5 February 2006, 15:06

Att du startade det första X med xdm eller motsvarande antog jag. Det gör jag också. Men när jag vill starta en X till går jag först till teminal 2 eller 3 och loggar in i den. Därifrån startar jag en ny X-session med startx -- :1 vt8 och då fungerar det att byta mellan sessionerna med CTRL+ALT+F7/F8.
Fagerjan

bol

Post by bol » 5 February 2006, 16:02

Funkar utmärkt för mig också.
Kör dock inte med någon grafisk inloggning.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 5 February 2006, 16:25

Hm, mysko det här. Förut har jag använt terminal 1. Men det blir samma i Term 2 eller 3.

Jag har ingen aning...
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 5 February 2006, 16:42

Hm, testade precis som root. Och nu funkade det.
Vad är fel?!
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 6 February 2006, 01:43

Kolla xauth att du har MIT-MAGIC-COOKIE-1 på display 1 som user.

Code: Select all

xauth
xauth> list
server/unix:0  MIT-MAGIC-COOKIE-1  a6c5354db59169c43846ef7e4e107bd8
localhost:0  MIT-MAGIC-COOKIE-1  g6h25c550180d63aa404f06582a4g6s3

xauth> add :1.0 MIT-MAGIC-COOKIE-1 a6c5354db59169c43846ef7e4e107bd8

xauth> list
server/unix:0  MIT-MAGIC-COOKIE-1  a6c5354db59169c43846ef7e4e107bd8
localhost:0  MIT-MAGIC-COOKIE-1  g6h25c550180d63aa404f06582a4g6s3
server/unix:1  MIT-MAGIC-COOKIE-1  a6c5354db59169c43846ef7e4e107bd8

xauth> exit
Men läs man xauth för exakt info.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 7 February 2006, 22:15

Code: Select all

emil@MegaLeif ~ $ xauth
Using authority file /home/emil/.Xauthority
xauth> list
62.101.44.145:0  MIT-MAGIC-COOKIE-1  a70b63744ab355a3074dd56d2d68f654
MegaLeif/unix:0  MIT-MAGIC-COOKIE-1  a70b63744ab355a3074dd56d2d68f654
[fe80::211:11ff:fe2a:31a2]:0  MIT-MAGIC-COOKIE-1  f98b8f6f85b871b512380cb96028059
Vad är "[fe80::211:11ff:fe2a:31a2]" för något? Vilken hexkey ska jag använda?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

mikma
Posts: 3349
Joined: 10 July 2003, 21:19

Post by mikma » 7 February 2006, 22:18

[fe80::211:11ff:fe2a:31a2] är en IPv6 adress.

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 7 February 2006, 22:35

Code: Select all

emil@MegaLeif ~ $ xauth
Using authority file /home/emil/.Xauthority
xauth> list
62.101.44.145:0  MIT-MAGIC-COOKIE-1  a70b63744ab355a3074dd56d2d68f654
MegaLeif/unix:0  MIT-MAGIC-COOKIE-1  a70b63744ab355a3074dd56d2d68f654
[fe80::211:11ff:fe2a:31a2]:0  MIT-MAGIC-COOKIE-1  f98b8f6f85b871b512380cb96028059e
MegaLeif/unix:1  MIT-MAGIC-COOKIE-1  a70b63744ab355a3074dd56d2d68f654
Men det funkar inte... Men jag får lite konstiga medelanden. Jag har iof alltid fått dem, men de kanske kan vara till hjälp.
Men det är ganska mycket. Finns det någon loggfil där allt som blivit skrivet i terminalen finns?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 9 February 2006, 17:55

aja, det funkar att starta med ssh, så det är huvudsaken.

Men går att att stara med:
startx --xxx

där xxx är vilken upplösning det ska vara?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
Jan Pihlgren
Posts: 1447
Joined: 22 April 2002, 02:00
Location: MÄRSTA
Contact:

Post by Jan Pihlgren » 9 February 2006, 19:16

Emil.s wrote:aja, det funkar att starta med ssh, så det är huvudsaken.

Men går att att stara med:
startx --xxx

där xxx är vilken upplösning det ska vara?
Prova!

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 9 February 2006, 22:11

Jan Pihlgren wrote:
Emil.s wrote:aja, det funkar att starta med ssh, så det är huvudsaken.

Men går att att stara med:
startx --xxx

där xxx är vilken upplösning det ska vara?
Prova!
det är bara det att jag inte vet vilket kommando jag ska använda. ;)
"man startx" gav inget som jag har nytta av i allafall...
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 9 February 2006, 23:27

Tycks inte finnas den möjligheten. Försök med

Code: Select all

 startx -screen namn
och definera en screen "namn" i xorg.conf.
Fagerjan

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 10 February 2006, 17:25

fagerjan wrote:Tycks inte finnas den möjligheten. Försök med

Code: Select all

 startx -screen namn
och definera en screen "namn" i xorg.conf.
Hur då. Jag har testat så här:

Code: Select all

Section "VNC"

    #Option "backingstore"
	Identifier "Screen0"
	Device     "ATI Graphics Adapter"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
  # initial origin if mode is smaller than desktop
#        Virtual     1280 1024
		Viewport   0 0
		Depth     24
		Modes  	"1024x768" "800x600" "640x480"
	EndSubSection
EndSection
=

Code: Select all

emil@MegaLeif ~ $ startx -name VNC -- :1

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/MegaLeif:1
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.14.1 i686 [ELF]
Current Operating System: Linux MegaLeif 2.6.15-gentoo-r1 #5 SMP PREEMPT Fri Jan 27 07:20:52 CET 2006 i686
Build Date: 14 January 2006
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Fri Feb 10 16:21:48 2006
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 453 of section VNC in file /etc/X11/xorg.conf
        "VNC" is not a valid section name.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.1.log" for additional information.

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
Couldnt get a file descriptor referring to the console
Men det står i klartext:
startx wrote: Parse error on line 453 of section VNC in file /etc/X11/xorg.conf
"VNC" is not a valid section name.
Så hur ska det se ut i xorg.conf?
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

Nille_kungen
Posts: 1506
Joined: 28 August 2005, 00:00

Post by Nille_kungen » 10 February 2006, 18:42

startx -- :1 eller xinit /etc/X11/xinit/xinitrc.fluxbox -- :1 borde fungera.
The more linux u go, The slacker u get

User avatar
Emil.s
Posts: 4366
Joined: 24 May 2005, 22:22
Location: Hedemora/Dalarna
Contact:

Post by Emil.s » 10 February 2006, 22:34

Nille_kungen wrote:startx -- :1 eller xinit /etc/X11/xinit/xinitrc.fluxbox -- :1 borde fungera.
startx -- :1 funkar. Men man loggas då in i KDE.
Med det andra blir det:

Code: Select all

emil@MegaLeif ~ $ xinit /etc/X11/xinit/xinitrc.fluxbox -- :1

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/MegaLeif:1
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.14.1 i686 [ELF]
Current Operating System: Linux MegaLeif 2.6.15-gentoo-r1 #5 SMP PREEMPT Fri Jan 27 07:20:52 CET 2006 i686
Build Date: 14 January 2006
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Fri Feb 10 21:32:26 2006
(==) Using config file: "/etc/X11/xorg.conf"
Using vt 8
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Cannot open "/var/tmp/server-1.xkm" to write keyboard description
>                   Exiting
(EE) Couldn't load XKB keymap, falling back to pre-XKB keymap
Could not init font path element /usr/X11R6/lib/X11/fonts/local/, removing from list!
xinit:  No such file or directory (errno 2):  no program named "/etc/X11/xinit/xinitrc.fluxbox" in PATH

Specify a program on the command line or make sure that /usr/bin
is in your path.


waiting for X server to shut down
Innan ni postar: Läs FAQen
När ni postar:
Posta i Rätt forum! Och skriv/formulera dig rätt

User avatar
fagerjan
Posts: 889
Joined: 21 December 2004, 18:05
Location: Dalsbruk, Finland
Contact:

Post by fagerjan » 11 February 2006, 16:15

Parse error on line 453 of section VNC in file /etc/X11/xorg.conf
"VNC" is not a valid section name.
Sektionsnamnet skall vara Screen. Indentifier skall ha ett annat värde än den normala.
Fagerjan

Post Reply